+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Error after Replacing trial license

Error after Replacing trial license

5 posts, 0 answered
  1. Kunal
    Kunal avatar
    1 posts
    Registered:
    10 Jul 2013
    02 Aug 2013
    Link to this post
    After replacing the trial license with our production license, I get the below error.





    Server Error in '/Default' Application.



    Invalid root node configured for pages. No root node with the name of "f669d9a7-009d-4d83-ddaa-000000000002".

      Description: An unhandled exception occurred during the execution of
    the current web request. Please review the stack trace for more
    information about the error and where it originated in the code.



     Exception Details: System.Configuration.ConfigurationErrorsException:
    Invalid root node configured for pages. No root node with the name of
    "f669d9a7-009d-4d83-ddaa-000000000002".



    Source Error:





     An unhandled exception was generated during the execution of the
    current web request. Information regarding the origin and location of
    the exception can be identified using the exception stack trace below.  



    Stack Trace:







    [ConfigurationErrorsException: Invalid root node configured for pages.
    No root node with the name of "f669d9a7-009d-4d83-ddaa-000000000002".]

       Telerik.Sitefinity.Web.SiteMapBase.Initialize(String name, NameValueCollection attributes) +2159

       System.Web.Configuration.ProvidersHelper.InstantiateProvider(ProviderSettings providerSettings, Type providerType) +578

      
    System.Web.Configuration.ProvidersHelper.InstantiateProviders(ProviderSettingsCollection
    configProviders, ProviderCollection providers, Type providerType) +114

       System.Web.Configuration.SiteMapSection.get_ProvidersInternal() +130

       System.Web.SiteMap.Initialize() +224

       System.Web.SiteMap.get_Providers() +5

       Telerik.Sitefinity.Web.SiteMapBase.GetSiteMapProvider(String rootName) +166

       Telerik.Sitefinity.Web.SitefinityRoute.GetSiteMapProvider() +16

       Telerik.Sitefinity.Web.SitefinityRoute.GetRouteData(HttpContextBase httpContext) +89

       System.Web.Routing.RouteCollection.GetRouteData(HttpContextBase httpContext) +200

       System.Web.Routing.UrlRoutingModule.PostResolveRequestCache(HttpContextBase context) +44

       System.Web.Routing.UrlRoutingModule.OnApplicationPostResolveRequestCache(Object sender, EventArgs e) +82

       System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +160

       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +70



     

  2. Pavel Benov
    Pavel Benov avatar
    341 posts
    Registered:
    14 Mar 2016
    07 Aug 2013
    Link to this post
    Hello Kunal,

    You have been answered in the support ticket you have submitted. Feel free to share the solution with the community. 

    Regards,
    Pavel Benov
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Ashok
    Ashok avatar
    1 posts
    Registered:
    04 Dec 2013
    13 Jan 2014
    Link to this post
    Hello,
    I'm experiencing this issue as well. If either of you could elaborate on the solution provided, it would be greatly appreciated. Thanks!
  4. Pavel Benov
    Pavel Benov avatar
    341 posts
    Registered:
    14 Mar 2016
    15 Jan 2014
    Link to this post
    Hello Ashok,

    Please take a look at the following KB article on the subject and try out the suggestions in it:

    http://www.sitefinity.com/developer-network/knowledge-base/when-sitefinity-project-is-deployed-to-production-server-an-invalid-root-node-configured-for-pages-no-root-node-with-the-name-of-frontendsitemap-error-is-thrown

    The issue with Kunal's project was the Multisite module which for some reason have changed the default site's root node id. Open your database and check the sf_sites table -> column site_map_root_node_id for your default site. If the GUID value is different from "f669d9a7-009d-4d83-ddaa-000000000002" go to your project's App_Data->Sitefinity->Configuration and open the ProjectConfig.config file. Should be looking something similar to this:

    <projectConfig xmlns:config="urn:telerik:sitefinity:configuration" xmlns:type="urn:telerik:sitefinity:configuration:type" config:version="6.3.5000.0" dateCreated="2014-01-09 08:26:58Z">
        <defaultSite id="1fde27dc-be4b-4fbd-bf1c-df09075ac0eb" name="Default" siteMapRootNodeId="f669d9a7-009d-4d83-ddaa-000000000002" />
    </projectConfig>

    Change the value of the siteMapRootNodeId to the GUID value in the database, save the config file and recycle the application. This should get your project up and running.

    Regards,
    Pavel Benov
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Omer
    Omer avatar
    0 posts
    Registered:
    15 Jul 2014
    09 Aug in reply to Pavel Benov
    Link to this post

    Hi Pavel

    My projectconfig.config file is damaged 

    and i cant find the defaultSite id

    where can i find it on database

    also how can i create a new one ?

    defaultsite id : ?

    siteMapRootNodeId: ?

    homePageId: ?

    name: Default same as before

    <?xml version="1.0" encoding="utf-8"?>
    <projectConfig xmlns:config="urn:telerik:sitefinity:configuration" xmlns:type="urn:telerik:sitefinity:configuration:type" config:version="7.1.5200.0" dateCreated="2014-07-24 12:44:40Z">
    <defaultSite id="0a11b19b-72de-497e-b79e-2db336a504e9" name="Default" siteMapRootNodeId="f669d9a7-009d-4d83-ddaa-000000000002" homePageId="f0a5b93c-3a5e-6548-9148-ff0000a3601c" />
    </projectConfig>

    no multi site is installed in my sitefinity

    best regards 

    omer

5 posts, 0 answered