+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Error from Load Balancing service

Error from Load Balancing service

2 posts, 0 answered
  1. Jon Jones
    Jon Jones avatar
    19 posts
    Registered:
    13 Aug 2003
    30 Jun
    Link to this post

    We have a 4 server setup.  3 front end servers and one staging/edit server.  All are setup in the load balancing configuration.  On application start and after changing a page I'm getting the following error (404) in the logs for each server in the farm and hence content updates are not being seen on each server.  I have gone through the docs and knowledge base articles related to this but can not find a cause or a solution.  I have setup WCF tracing on all nodes and I can not see that the service calls are even getting to the servers, but I have verified that the urls of the front ends are accessible from the edit server.  Any help would be greatly appreciate since I have been working on this all day.

    Thanks...

    ----------------------------------------
    Timestamp: 6/30/2016 9:04:58 PM

    Message: HandlingInstanceID: dd89b54f-ba6d-4207-b1d3-44aa524d20bd
    An exception of type 'System.Exception' occurred and was caught.
    ----------------------------------------------------------------
    06/30/2016 16:04:58
    Type : System.Exception, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Message : Error sending system message to URL: http://sitefinity2/Sitefinity/Services/LoadBalancing/SystemWebService.svc/HandleMessages; HTTP method: PUT; Host: 'sitefinity2'
    Source : 
    Help link : 
    Data : System.Collections.ListDictionaryInternal
    TargetSite : 
    HResult : -2146233088
    Stack Trace : The stack trace is unavailable.
    Additional Info:

    MachineName : WEBSSIIS02
    TimeStamp : 6/30/2016 9:04:58 PM
    FullName : Telerik.Sitefinity.Utilities, Version=9.1.6110.0, Culture=neutral, PublicKeyToken=b28c218413bdf563
    AppDomainName : /LM/W3SVC/45/ROOT-3-131117942645143315
    ThreadIdentity : 
    WindowsIdentity : IIS APPPOOL\sSitefinity
    Inner Exception
    ---------------
    Type : System.Net.WebException, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Message : The remote server returned an error: (404) Not Found.
    Source : System
    Help link : 
    Status : ProtocolError
    Response : System.Net.HttpWebResponse
    Data : System.Collections.ListDictionaryInternal
    TargetSite : System.Net.WebResponse EndGetResponse(System.IAsyncResult)
    HResult : -2146233079
    Stack Trace :    at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
      at Telerik.Sitefinity.LoadBalancing.WebServiceSystemMessageSender.WithExceptionHandling(String url, String httpMethod, String hostHeader, Action action)



    Category: ErrorLog

    Priority: 0

    EventId: 9010

    Severity: Warning

    Title:Enterprise Library Exception Handling

    Machine: WEBSSIIS02

    App Domain: /LM/W3SVC/45/ROOT-3-131117942645143315

    ProcessId: 2648

    Process Name: c:\windows\system32\inetsrv\w3wp.exe

    Thread Name: http://sitefinity2/Sitefinity/Services/LoadBalancing/SystemWebService.svc/HandleMessages-Thread-1

    Win32 ThreadId:4148

    Extended Properties: 
    ----------------------------------------

  2. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    Registered:
    23 Sep 2016
    05 Jul
    Link to this post
    Hello,

    As you have noted in the support ticket it has appeared that the WCF service mapping have not been installed correctly.  After uninstalling and reinstalling HTTP Activation everything is working properly.

    Sabrie Nedzhip
    Telerik by Progress
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
2 posts, 0 answered