+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Error moving from one server to another

Error moving from one server to another

5 posts, 0 answered
  1. Brandon
    Brandon avatar
    16 posts
    Registered:
    23 Oct 2008
    20 Apr 2011
    Link to this post
    Hi,
      I'm trying to move a 4.0 website from one server to another.  It's using SQLExpress 2008 as the DB.   I've backed up/restored the db from old server to new.  I also copied the website files from the original server to the new one.  I changed the DataConfig.config file to point to new db.  I get the following error:

    Invalid root node configured for pages. No root node with the name of "FrontendSiteMap".

    Is that a licensing error? Or a database connection error?  Or is IIS not setup right?

    Thanks,
    Brandon

  2. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    21 Apr 2011
    Link to this post
    Hi Brandon,

    Please take a brief look at the following forum thread where my colleague Ivan explained possible reasons for the error you are getting:

    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/bugs-issues/error-invalid-root-node-configured-for-pages-no-root-node-with-the-name-of-quot-frontendsitemap-quot.aspx

    Regards,
    Victor Velev
    the Telerik team

  3. Brandon
    Brandon avatar
    16 posts
    Registered:
    23 Oct 2008
    21 Apr 2011
    Link to this post
    Hi thanks,
      The sql database was recreated (I think maybe the connection string was incorrect).  Regardless, I deleted the new (empty) database, renamed the original one to match the one it created and everything came up.

    Thanks,
    Brandon
  4. Rick
    Rick avatar
    32 posts
    Registered:
    13 Dec 2006
    12 Sep 2012
    Link to this post
    I am getting this same error as well and I have followed all the steps here

    http://www.sitefinity.com/devnet/kb/sitefinity-4-x/when-sitefinity-project-is-deployed-to-production-server-an-invalid-root-node-configured-for-pages-no-root-node-with-the-name-of-frontendsitemap-error-is-thrown.aspx 

    The only question I am having on those steps, on the project naming issue What do I need to change it to or do I need to change it to anything if is is deployed under root or is that simply an internal naming convention used by the project.

    Also in my DB it has 2 sets of the tables one dbo and one with my username.

    Any help would be appreciated.
  5. Rick
    Rick avatar
    32 posts
    Registered:
    13 Dec 2006
    12 Sep 2012
    Link to this post
    I am getting this same error as well and I have followed all the steps here

    http://www.sitefinity.com/devnet/kb/sitefinity-4-x/when-sitefinity-project-is-deployed-to-production-server-an-invalid-root-node-configured-for-pages-no-root-node-with-the-name-of-frontendsitemap-error-is-thrown.aspx 

    The only question I am having on those steps, on the project naming issue What do I need to change it to or do I need to change it to anything if is is deployed under root or is that simply an internal naming convention used by the project.

    Also in my DB it has 2 sets of the tables one dbo and one with my username.

    Any help would be appreciated.
5 posts, 0 answered