+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Problem of authentication schemes in the backend

Problem of authentication schemes in the backend

6 posts, 0 answered
  1. DUCRET
    DUCRET avatar
    3 posts
    Registered:
    04 Jul 2011
    05 Aug 2011
    Link to this post
    Hi,

    I deployed my sitefinity website in Amen host. Everything looks like fine excepted one: when i go to the page section in the backend i have this message : 

    IIS specified authentication schemes 'Basic, Anonymous', but the binding only supports specification of exactly one authentication scheme. Valid authentication schemes are Digest, Negotiate, NTLM, Basic, or Anonymous. Change the IIS settings so that only a single authentication scheme is used.

    My site is host in a hosting society so i cannot change the parameter of IIS 7. What should I do??

    Thanks,

    Fabien
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    05 Aug 2011
    Link to this post
    Hello Ducret,

    Please make sure that you have Annonymous and Forms Authentication enabled in IIS. All other authentication types should be disabled.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DUCRET
    DUCRET avatar
    3 posts
    Registered:
    04 Jul 2011
    05 Aug 2011
    Link to this post
    Hi Ivan,

    That's my problem, I cannot do this because I have no access to the IIS server... Any others ideas? Should I change something in the web.config?

    Thanks,

    Fabien
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    05 Aug 2011
    Link to this post
    Hi Ducret,

    This is  a server side setting which is not controlled by Sitefinity. You can ask your host if it allows changing the authentication with config files or choose another plan that they allows accessing the IIS.


    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. DUCRET
    DUCRET avatar
    3 posts
    Registered:
    04 Jul 2011
    12 Aug 2011
    Link to this post
    Hi Ivan,

    Thanks for your answer. My host allows me to changing the authentication with config files. But what's the correct syntax to change authentication in the web.config?

    Thanks,

    Fabien
  6. Dimitar
    Dimitar avatar
    19 posts
    Registered:
    17 Nov 2016
    17 Aug 2011
    Link to this post
    Hello Ducret,

    The easiest way to to this is by setting the mode of the authentication element in the web.config to Forms as shown below.

    <configuration>   
    <system.web>
    <authentication mode="Forms"/> </system.web> </configuration> I hope this will solve the issue but if you still experience a problem - don't hesitate to ask for help.


    Kind regards,
    Dimitar Boyanov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
6 posts, 0 answered