+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Sitefinity 4 - Let's talk about downgrading.

Sitefinity 4 - Let's talk about downgrading.

4 posts, 0 answered
  1. Troy Thompson
    Troy Thompson avatar
    4 posts
    Registered:
    03 Apr 2009
    11 Mar 2011
    Link to this post
    I have created a website for a client using Sitefinity 4.  Specifically, I believe the version is "Sitefinity 4.0.962.0 CE". (Assumed from the content of a Sitefinity <meta> tag within the page source)

    During development, there was no constraint on the version of the .NET Framework, but I now realize that the client's webhost is 1&1.  This brings about numerous issues:

    The current level of the .NET framework on their site is .NET 2.0, but 1&1 support has informed me that I can have this upgraded to 3.5 by moving to a newer hosting plan.  Despite that being an option, it wouldn't solve the problem.

    After some "research" (if that's what people are calling a few Google queries these days) I believe that there was a beta version of Sitefinity, released sometime prior to the version I'm currently using, that targeted the .NET 3.5 Framework.

    I'm not exactly delighted at running a beta build in a production environment (On the other hand, I believe this version of Sitefinity is a Release Candidate), but I'm willing to work around any issues that might arise in hopes of not imposing on my client.

    All that said, I've got a few summarized questions regarding this:

    1. I couldn't find any download location for previous Sitefinity builds/releases.  Are those still available?

    2. More importantly, was there a previous Sitefinity release, preferably something in the same family as version 4, beta or otherwise, that targeted the .NET 3.5 framework?

    3. Is the level of trust given to ASP.NET applications on 1&1 relaxed enough for Sitefinity?  On their FAQ, they have an article about ASP.NET trust, that can be found here: http://faq.1and1.com/scripting_languages_supported/asp_net/14.html - A previous thread referenced this link (actually, copy/pasted the data from the page), but it was in regards to Sitefinity 3. (this thread is located here: http://www.sitefinity.com/devnet/forums/sitefinity-3-x/3-x-pre-release-forums-retired/1and1com-web-hosting-net-issues.aspx )
  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    11 Mar 2011
    Link to this post
    The RC you're talking about is no where near buildable, and riddled with bugs, and I'm not even sure the licensing on it would allow it to be run in Prod...

    You realistically have two choices
    1) Downgrade to 3.7
    2) Get a new Host that supports .net4
  3. Troy Thompson
    Troy Thompson avatar
    4 posts
    Registered:
    03 Apr 2009
    12 Mar 2011
    Link to this post
    You mentioned downgrading to 3.7.

    I didn't come across any other version than the current one.  Where can I obtain it?
  4. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    12 Mar 2011
    Link to this post
    Oh wait, community edition is not available anymore, you are right...not sure if 3.x standard can still be obtained :o

    You will look horrible to your client if you try and deploy with the RC, and there might even be an expiry on it where it'll stop working
4 posts, 0 answered