+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Speed up loading

Speed up loading

11 posts, 1 answered
  1. Owain
    Owain avatar
    110 posts
    Registered:
    17 Jan 2012
    30 Jun 2012
    Link to this post
    Hi, 
    We are approx 5 weeks away from launching our new website but I have one main concern, the load times for the initial visit to the site. 
    It can take a good 10-15seconds to load pages - this is meant to be a new and improved website but the way things are going, people are going to be complaining about the load times.
    How do I make our site load faster? There isnt anything complicated on any of the pages, most of them are just text.

    Thanks in advance,
     
  2. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    01 Jul 2012
    Link to this post
    Hey Owain,

    The best thing you could do is take a vacation now and come back around the 19th when v5.1 will be launched.

    According to the roadmap, tweets and remarks here and there on the forums v5.1 is going to show significant speed bump with partial (on demand) back-end loading and Javascript & ORM enhancements on the front. Also they'll start using KendoUI for an even faster & smoother experience.

    All marketing bla-bla I know, but for instance the RadControls used will be Q2 2012 which means no double loading of jQuery and actual compressed resources. (maybe not an 'initial visit' enhancement example, but you see they'll measurably speed up Sitefinity).

    Once that's released you can start looking again in things like caching & keeping the site warm...
  3. Owain
    Owain avatar
    110 posts
    Registered:
    17 Jan 2012
    02 Jul 2012
    Link to this post
    As much as I like your suggestion its not really an option. The launch date has already slipped by a month and I don't really want to delay it any further. I like the sound of 5.1 and will be upgrading when it rolls out but is there anything we can do in the meantime to speed the site up?

  4. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    02 Jul 2012
    Link to this post
    Hey Owain,

    Of course there are, let's walk through a few.

    On the server side, try and tweak/optimize the setting so the processes won't go to sleep or recycle 'to often'. This will keep your cache warm and avoid the first-hit waiting period. If you can't optimize app-pool settings etc you can opt to write a 'warm up script' that runs as a scheduled job on your server or use an external service to ping your website on regular intervals.

    If you're gonna run on IIS 7.5 you might want to checkout the Application Initialization module for IIS, which basically fixes the first-request issue by doing some magic pre-loading.

    ---

    In terms of Sitefinity/website have you verified your caching & compression settings in the web.config? They should read something like this
    <staticContent>
      <clientCache
       cacheControlMode="UseExpires"
       httpExpires="Sun, 29 Mar 2020 00:00:00 GMT"  />
     </staticContent>
    <urlCompression
      doDynamicCompression="true"
      doStaticCompression="true"
      dynamicCompressionBeforeCache="false"
    />

    (the expires date naturally depends on your preference, for reference click here).

    And finally there's switching from a Visual Studio 'Website' to a 'Web application' in case you've got many custom code behinds. The 'web application' project basically compiles everything into a dll instead of compiling it on runtime each time the app-pool's been recycled.

    ---
    And lastly, there's Fiddler, YSlow and your favorite browser developer tools to help you further identify and optimize page loads...

    Jochem
  5. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    06 Jul 2012
    Link to this post
    Also if you're on MSSQL

    THIS
    Answered
  6. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    31 Jul 2012
    Link to this post
    Just registering myself for this thread.
  7. Owain
    Owain avatar
    110 posts
    Registered:
    17 Jan 2012
    08 Aug 2012
    Link to this post
    Well, I've upgraded to 5.1 SP1 and sadly the site is still running really slowly. A bit annoying really. Anyone else finding this?
  8. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    08 Aug 2012
    Link to this post
    Do you mean the front-end or the back-end? The fron-end I am not aware of any major changes. The back-end there is a difference. I find the back-end to be a little bit quicker. Although, with heavy use of AJAX I find myself looking at the screen very often and wondering "did my click register or not ???". Heavy use of AJAX requires powerful machines, otherwise it just looks like nothing is happening for a few seconds and then all of a sudden it loads. I don't know, but I think when it comes to AJAX, it should be used like salt (a little goes a long way). So yes, the backend is a bit faster for me with half of the modules disabled, but the publishing has actually slowed down based on a very heavy page (15 controls) that I have. So mixed results really. I am wondering will it get even faster? Where is the performence on the Telerik priorities list?
    Cheers,
    Andrei
  9. TMatt
    TMatt avatar
    104 posts
    Registered:
    06 Feb 2011
    09 Aug 2012
    Link to this post
    I can´t see any difference in backend speed.

    For me it´s same as before.

    To become a fast first Website for customer it´s importend to hold your Website hot.

    I do this with a l Service on my webserver which loads the site every x minutes.

    So the site is hot every time. Like Jochem told before.



    I will test now Jochems link to Application Initialization for IIS 7.5. Ok this is much complexer and more work than a Service :) We use our service
  10. TMatt
    TMatt avatar
    104 posts
    Registered:
    06 Feb 2011
    09 Aug 2012
    Link to this post
    What i also see is that mem usage of Sitefinity 5.1  is higher then in 5.0.

    I tested out of the box fresh install. And i have disabled modules in Sitefinity 5.1
  11. Glenn
    Glenn avatar
    10 posts
    Registered:
    22 Jan 2007
    15 Aug 2012
    Link to this post
    subscribing to this thread. we are seeing the same thing in 5.1 as well for performance. We have three web servers (two production and one for editing) all a pointing to the same database. Why does it take so long to load a page for the initial request? I under the whole asp.net page life cycle compiles request first time and fast subsequent times buuuuttttttt just seems it's still too slow.
11 posts, 1 answered