+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Transferring Sitefinity Website to .NET 4.0

Transferring Sitefinity Website to .NET 4.0

9 posts, 0 answered
  1. Paul N
    Paul N avatar
    55 posts
    Registered:
    24 Apr 2010
    16 May 2011
    Link to this post
    Hi guys,

    I have a few quick questions about moving our Sitefinity 3.7 SP3 (on .NET 3.5) to a new hosting provider (on .NET 4.0). We've transferred across the files and database, and the site is working on this new provider (it is using a temporary URL while we get it working). The question I have is do we need to upgrade the sitefinity .NET version to 4.0? and if so should we install Sitefinity with .NET 4 locally on a computer, and then update the files online, or can we just install the SP3 hotfix for .NET 4?

    Also 1 other question I have is when we loaded the temporary site, it said we were using a trial of sitefinity, and when i try and add controls to pages etc, it doesnt work. So I'm wondering if that's because it's on a trial?

    Any help would be great.

    Thanks,
    Paul
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    16 May 2011
    Link to this post
    Hello Paul N,

    If your provider supports only .NET 4.0, you should upgrade the project with the patch for .NET 4.0 that we ship. Generally there are small changes in the web.config and some of the templates between SP3 and SP4(which supports .NET 4.0) and everything else is code fixes.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Paul N
    Paul N avatar
    55 posts
    Registered:
    24 Apr 2010
    16 May 2011
    Link to this post
    Hi Ivan,

    Just remembered we are currently on SP4, we need to build some .NET 4 controls, so thats why we've transfered to a .NET 4 provider, it does support .NET 3.5, as the website is working there.

    So just installing the patch/hotfix for .NET 4 should be enough? We dont need to reinstall sitefinity?

    Thanks for the help,
    Paul
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    16 May 2011
    Link to this post
    Hi Paul N,

    If you have SP4 , .NET 3.5, you should only replace the dlls in the bin folder and make web.config merge. If you have custom templates you should also check if there are difference between .NET 3.5 and 4.0 version.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Paul N
    Paul N avatar
    55 posts
    Registered:
    24 Apr 2010
    16 May 2011
    Link to this post
    Thanks Ivan,

    Do you know anything about the other question I had? About the trial version, and not being able to add controls to pages?

    Thanks,
    Paul
  6. Paul N
    Paul N avatar
    55 posts
    Registered:
    24 Apr 2010
    17 May 2011
    Link to this post
    Hi Ivan,

    Still having trouble getting sitefinity set up on this new .NET 4 account.

    We are now trying to use the .NET 4 files from the patch, and just using the 'bin' and 'sitefinity' folders, as well as the new 'web.config' from there to try get it working first, but when we reload the site we are getting a page asking to select our database (even though we've already entered the correct connection string in the web.config). Even if we try and connect to the DB using that tool we get an error saying access denied to the page.

    If you know of anything to fix this please let me know. Maybe we're trying to do this the wrong way?

    Thanks,
    Paul
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    18 May 2011
    Link to this post
    Hi Paul N,

    Have you merged the web.config? There are small difference there.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Paul N
    Paul N avatar
    55 posts
    Registered:
    24 Apr 2010
    18 May 2011
    Link to this post
    Thanks Ivan,

    We've got it working again, it was a permissions issue with our hosting provider.

    There's just a few controls that will need fixing now, for some reason the Generic Content controls are showing an error on the page editor screen "object reference not set to an instance of an object". But they still display correctly on the site, so we will just need to go through those to fix them.

    Thanks again,
    Paul
  9. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    24 May 2011
    Link to this post
    Hi Paul N,

    We are now closing the thread. Let us know if we could be of further help though.

    Greetings,
    Georgi
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
9 posts, 0 answered