+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Backup and restore

Backup and restore

8 posts, 0 answered
  1. Yin
    Yin avatar
    3 posts
    Registered:
    15 Jun 2009
    06 Jul 2009
    Link to this post
    Hi,

    Would like to know if there's any proper guideline on how to backup a sitefinity+database from server A and restore into server B?

    Thank you.
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    20 Sep 2016
    06 Jul 2009
    Link to this post
    Hi Yin,

    Thank you for your question.

    We do not have a specific guide for this task. Sitefinity databases are not different than the others, and depending on the database engine can be backup and restored by following the common practices.

    Let us know if you have any other questions, or need assistance.

    Regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Yin
    Yin avatar
    3 posts
    Registered:
    15 Jun 2009
    07 Jul 2009
    Link to this post
    Hi Georgi,

    Thanks for the reply!

    So, do you mean that to backup a sitefinity + database, I need to do it manually?  Last night I've used MS SQL 2005 backup tool to backup my database from server A and then restore it to server B, which is clone from server A before I start doing customization in server A.  Somehow, it successfully restore but when I browse into my site, it could not display anything and resulting my whole sitefinity "died". 
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    19 Sep 2016
    07 Jul 2009
    Link to this post
    Hello Yin,

    Generally this process is standard backup of a SQL ( or other type) database. You create a backup, then restore it on another server. Then you need to change the connection string in your web.cofig to point to the new server. If necessary you should add login user.
    Did you get any errors when you ran the website with the restored database?

    All the best,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  5. Ravindra
    Ravindra avatar
    3 posts
    Registered:
    20 Jul 2010
    24 May 2011
    Link to this post
    Hi Ivan,

    I have taken the site backup as well as database backup from production server and restore it to my local machine
    After that i have made the changes for connection string in the dataconfig file (AppData-->sitefinity-->Configuration)

    Check the attachment for errors.

    I am not able to see the homepage on local server (Error1.png)  what i have in my production server
    I am not able to login (Error2.png)
    but user is exist in the database.

    What is going wrong. Can you help me on solving the error?

    Thank you

    Regards
    Ravindra Sahasrabudhe
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    19 Sep 2016
    26 May 2011
    Link to this post
    Hi Ravindra,

    You could get this error if

    1. The project name has been changed - the name of the project is not the same as this one used when the project was installed

    You could check  App_Data\Sitefinity\Configuration\ProjectConfig.config file and projectName attribute. By default the attribute is not added to the config file. It is added after project installation The project name is used as an identifier by us.

    2. In some case the error could appear if the connection to the database is lost. Would you check the connection to the database in the DataConfig.config file?

    3. If the connection string is different, make sure that in both environments the database user is db_owner or it is the same user. For example, if the user is db_owner it creates tables with dbo.tableName, if it is not - userName.tableName, which are two different tables. Maybe the data has not been published correctly. Could you please open sf_page_node table and make sure that it is not empty and the value of the app_name column for all records is '[ProjectName_From_ProjectConfig]/'.


    Also check whether there are not changes to the App_Data/Sitefinity/Configuration.

    These files -  config files are closely related to the database.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Ravindra
    Ravindra avatar
    3 posts
    Registered:
    20 Jul 2010
    26 May 2011
    Link to this post
    Hi Ivan,

    Thank you for your reply but problem is there. Sorry i didnot mention sitefinity version.
    I am using sitefinity 4.0.1098 standard Edition

    I have attached the screenshot for your each step which i followed. 2 and 3 are correct
    I am not sure about 1 because i could not found project name attribute in the projectConfig.config.
    How project name will change.


    Please let me know.

    Regards
    Ravindra Sahasrabudhe
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    19 Sep 2016
    29 May 2011
    Link to this post
    Hi Ravindra,

    You can check the project name if you navigate to sitefinity/Administration/Settings, but most probably the issue is related to 2 or 3, because changing the project name requires to manually update the configuration files which I suppose you didn't make.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
8 posts, 0 answered