+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Cannot Login to Admin after Deployment

Cannot Login to Admin after Deployment

6 posts, 0 answered
  1. Dawn
    Dawn avatar
    37 posts
    Registered:
    17 Sep 2012
    16 Aug 2009
    Link to this post
    I deployed my site to discountasp.net following the instructions here: http://www.sitefinity.com/support/kb/sitefinity-3-x/discount-asp-net-hosting-provider.aspx

    However, when I go to login to the admin area none of my passwords work. I get the message: Your login attempt was not successful. Please try again.

    I checked and rechecked all the instructions. I also checked and rechecked my passwords and login info. I even looked into the Telerik_Users table and verified that the users are in there.

    What am I missing?


  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Aug 2009
    Link to this post
    Hi Robert,

    Make sure that you are running in the same application pool as you used on your dev server. If the problem persists try resetting your password following instructions from this article. Let us know how it goes.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Dawn
    Dawn avatar
    37 posts
    Registered:
    17 Sep 2012
    17 Aug 2009
    Link to this post
    Thanks for your feedback!

    It appears that the problem has to do with the fact that I had CSS Friendly Control Adapters in the App_Code folder. That was interfering with the login control.

    Removing that fixed the problem. It seems that Sitefinity does not work well with those adapters.




  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Aug 2009
    Link to this post
    Hi Robert,

    There could be some level of interaction, but there was no way to know this from your post. It is good to know that everything is working fine at your end. If you face any other problems, please write back to us.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  5. Dawn
    Dawn avatar
    37 posts
    Registered:
    17 Sep 2012
    17 Aug 2009
    Link to this post
    It wasn't until I was going through your suggested solution that it dawned on me that there was something in my application that was interfering with the login control. Then I remembered the control adapters. I removed the .cs files from the App_Code directory and that fixed it. So you're saying that it is possible for Sitefinity to work with these adapters?


  6. Sean
    Sean avatar
    271 posts
    Registered:
    31 May 2006
    18 Aug 2009
    Link to this post
    Hi Robert,

    I have used the control adapters on a couple of projects and have since removed it from them.  The CSS Control Adapters don't seem to be fully complete and you will run into a host of problems if you need to customise any of the login controls and these problems don't seem to be related just to Sitefinity.

    I would recommend not using the CSS Control Adapters unless you really really have to :)

    Cheers
    Sean
Register for webinar
6 posts, 0 answered