+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Default Pages

Default Pages

5 posts, 0 answered
  1. Raymond Dowe
    Raymond Dowe avatar
    37 posts
    Registered:
    10 Mar 2010
    10 Jun 2010
    Link to this post
    I'm experiencing some strange behaviour with Sitefinity and I was hoping someone could explain why things are happening.

    I've got a site running that has pages with both an English and a French version. I've setup "SplashPage" to be the default homepage. When I go to "mydomain.com", it redirects to "mydomain.com/en/SplashPage.aspx" and all is well.

    What is strange, is that when I go to "mydomain.com/en/", it gives me a page not found error. I would have thought sitefinity would handle this more gracefully.

    To fix this I actually created an "en" folder in my site root. That changes the error to the standard can't browse folder, no index. If was going to create an aspx page to redirect to "/", but when I did that I noticed the page doesn't ever get hit. The simple act of putting a BLANK Default.aspx in the "en" folder is enough to shake sitefinity and it now redirects to my CMS selected homepage.

    Anyone know what's going on? Seems strange to me.
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    14 Jun 2010
    Link to this post
    Hello Raymond Dowe,

    Could you try setting you splash page as home page from Sitefinity admin? Please take a look at the attached picture to see how to achieve this.

    Kind regards,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Raymond Dowe
    Raymond Dowe avatar
    37 posts
    Registered:
    10 Mar 2010
    14 Jun 2010
    Link to this post
    Yes, this is what I did. It's what I meant when I said at the beginning of paragraph 2, "I've setup 'SplashPage' to be the default homepage".

    Because of I have an English and French version of the site, when I visit http://mydomain.com, it redirects to http://mydomain.com/en/SplashPage.aspx.

    My problem, or really just more of a strange occurrence, is when I visit http://mydomain.com/en/

    Does this clarify?
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    14 Jun 2010
    Link to this post
    Hello Raymond Dowe,

    Could you please tell me which version of Sitefinity are you using? Please follow the steps from this article to find about your version.

    I am using Sitefinity 3.7 SP3 and this problem cannot be reproduced, considering that I do not have an en folder in the root of my site. You can take a look at the attached video for reference.

    Regards,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Raymond Dowe
    Raymond Dowe avatar
    37 posts
    Registered:
    10 Mar 2010
    14 Jun 2010
    Link to this post
    <meta name="Generator" content="Sitefinity 3.7.2096.2:17" />

    1. Originally, I setup the site homepage through sitefinity. I had no /en folder. When browsing to mydomain.com/en/, I get a page not found error.

    2. I created the /en folder. The error changes to can't browser / no index

    3. Added a BLANK default.aspx page to the /en folder. Now sitefinity redirects to mydomain.com/en/splashpage.aspx appropriately
Register for webinar
5 posts, 0 answered