+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Deployment to Intermedia Shared Hosting

Deployment to Intermedia Shared Hosting

5 posts, 0 answered
  1. Candace Sweigart
    Candace Sweigart avatar
    7 posts
    Registered:
    06 Jul 2009
    04 Aug 2009
    Link to this post
    Hi there,

    I'm having difficulty getting my localhost Sitefinity Commuity Edition project configured/working on my shared hosting server with Intermedia.  I've followed the instructions in the user's guide for "Installing Sitefinity in a Shared Hosting Environment", although the instructions were using Discount ASP.NET.

    Here is my problem...

    I was able to install the database and FTP all of my project files to the server without a problem.  I setup a virtual directory for my application and currently can view the front-end web app just fine at my domain.  The site itself looks great! 

    However, when I try to login to the admin tool, nothing happens.  When I enter my username and password for the admin account, the form just resets itself and I'm not logged in.  If I enter an incorrect password, I get the incorrect password error, so I know that I am properly entering my credentials.  Also, when I use my localhost project (connecting to the production database server on Intermedia), I am able to login to the admin screen and administer the site without a problem.  So my real problem is that I can't seem to login to the admin section of the site using the project that is on my production server.  Feels to me like maybe this is an IIS setting issue? 

    Can anyone help me with this problem?  I love this product and would like to use it for my customers but I would really like to use my preferred hosting vendor and it just simply won't do to not be able to administer the site from anywhere but localhost.  Also, this initial community edition installation was a "test project" and I'm using it to evaluate the product.  I really can't see recommending this product to my clients without the ability to migrate to my production server of choice.

    Please help!

     
  2. Candace Sweigart
    Candace Sweigart avatar
    7 posts
    Registered:
    06 Jul 2009
    04 Aug 2009
    Link to this post
    I'd like to add one more detail...I was getting the following error every time I tried to login:

    Validation of viewstate MAC failed. If this application is hosted by a Web Farm or cluster, ensure that <machineKey> configuration specifies the same validationKey and validation algorithm. AutoGenerate cannot be used in a cluster.


    In order to fix this, I added the following to my web.config:
    <pages enableEventValidation="false">

    While this fixed my problem with getting this error, it created the new problem of the webform not allowing me to sign in.

  3. Candace Sweigart
    Candace Sweigart avatar
    7 posts
    Registered:
    06 Jul 2009
    04 Aug 2009
    Link to this post
    The problem appears to have solved itself.  I thought for sure that it was an IIS issue, but it seems that IE8 was actually just storing the cookie/form data in such a way that I wasn't realizing that my problem was fixed with the web.config change.  When I tried it in Firefox it worked perfectly and that was my clue.  Hopefully this post helps someone else and I'm happy to report a successful install with Intermedia shared hosting. 
  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    05 Aug 2009
    Link to this post
    Hello Candace Sweigart,

    We are glad that everything is fine. Hopefully you will not see the problem again, and the other community members will benefit from your experience as well.

    Don't hesitate to contact us if you have other questions.


    Sincerely yours,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the newTelerik Support Portal.
    Check out the tipsfor optimizing your support resource searches.
  5. Candace Sweigart
    Candace Sweigart avatar
    7 posts
    Registered:
    06 Jul 2009
    05 Aug 2009
    Link to this post
    Thanks Georgi.  So far I am very pleased with Sitefinity and the support.  I appreciate your help.
Register for webinar
5 posts, 0 answered