+1-888-365-2779
Try Now
More in this section

Forums / Deployment / help! moved Sitefinity site to a new host and pages are broken

help! moved Sitefinity site to a new host and pages are broken

4 posts, 0 answered
  1. ColdCold
    ColdCold avatar
    9 posts
    Registered:
    14 Mar 2010
    21 Jul 2010
    Link to this post
    Hello all,

    I'm relatively new to Sitefinity.  I have a working SF site at one host and I'm trying to recreate it on another host.  In the past I would just copy the entire file structure to the new host, restore the DB backup on the new host, edit the connection string in web.config and everything works.  For some reason when I did it this time, all the internal pages are getting 404 errors.  I can login to Sitefinity and see all my pages in the sitemap listing but when I click a page to go look at / edit it, I just get a 404 error.  The home page is working in the live site but all the subpages that should be there are getting 404 errors.

    How does Sitefinity manage URLs?  Is there a sitewide setting that affects virtual paths or something?  Since they are not physical files and data should be coming out of the database, I'm confused that it's giving me 404 errors when the database seems to be working.

    Can anyone suggest a troubleshooting approach?

    thank you,

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    21 Jul 2010
    Link to this post
    Hi ColdCold,

    We use relative urls which means that moving from one virtual directory to another is not a problem. Could you check whether there is handler mapping for .aspx in IIS. The problem is somewhere in the server where you have hosted the project.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Karen
    Karen avatar
    22 posts
    Registered:
    04 Aug 2010
    16 Aug 2010
    Link to this post
    This is actually exactly what I am experiencing and cannot fix during last 2 weeks, hosting provider says that aspx mappings are mapped correctly otherwise other asp.net websites wouldn't work either, but I still get 404 error ((
  4. ColdCold
    ColdCold avatar
    9 posts
    Registered:
    14 Mar 2010
    17 Aug 2010
    Link to this post
    Karen,

    What I didn't know when I first posted my question is about the "sf404.aspx" page that is built-in to Sitefinity.  If you read through this post you will find a discussion about it.  http://www.sitefinity.com/devnet/forums/sitefinity-3-x/general-discussions/directory-structure-default-homepage.aspx

    There is more here:

    http://www.sitefinity.com/devnet/forums/sitefinity-3-x/developing-with-sitefinity/extensionless-urls.aspx

    Hope that helps.
Register for webinar
4 posts, 0 answered