+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Images in library not visible when deployed

Images in library not visible when deployed

7 posts, 0 answered
  1. Andy
    Andy avatar
    62 posts
    Registered:
    01 Aug 2008
    10 Nov 2008
    Link to this post
    Hi,

    I've just deployed a site that was developed locally.

    On the live server, when viewing the contents of the image library, the image thumbnails don't appear. Also they don't appear when viewed in the site.

    I can create a new 'test' library, upload a new image to it, and still the thumbnail is not visible.

    Do you have any idea what might be happening? IIS configuration issue?

    Thanks!
    Andy
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    10 Nov 2008
    Link to this post
    Hi Andy,

    To be able to download files and see images and thumbnails in the Images & Documents module, you should set the ISAPI mappings for .sflb and .tmb extensions on your IIS virtual directory. These should be set automatically by the Sitefinity installer; however, you need to add them manually if you have upgraded using a patch or if you are deploying the site on another server.

    Check out our troubleshooting section Troubleshooting. If the problem persists, please let us know which version you are running.

    I hope this helps.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. Andy
    Andy avatar
    62 posts
    Registered:
    01 Aug 2008
    10 Nov 2008
    Link to this post
    Fantastic. Thanks again Ivan. I thought it might be something like that.
  4. Jonathan
    Jonathan avatar
    13 posts
    Registered:
    16 Jun 2012
    23 Jan 2009
    Link to this post
    So how can you fix this problem if you are hosting a site with a provider that doesn't give you IIS access?
  5. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    26 Jan 2009
    Link to this post
    Hello Jonathan Marbutt,

    If the hosting is running with IIS7, then you can add the extension handlers in the web.config file, section <system.webserver>. If the host is not running IIS7, we recommend to ask the hosting provider to add these extensions for you.
    In Sitefinity 3.5, there is no need for this custom handlers, because we use standard ones, which are enabled on the server by the default settings.

    Regards,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  6. Jonathan
    Jonathan avatar
    13 posts
    Registered:
    16 Jun 2012
    01 Feb 2009
    Link to this post
    Is there no way around this? I have a site using a host that doesn't give us that level of access and will not add it.


  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    02 Feb 2009
    Link to this post
    Hello Jonathan Marbutt,

    I regret to inform you that there are no other ways that I could suggest except adding the extension handlers in the web.config manually or set them directly through IIS.

    Greetings,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Register for webinar
7 posts, 0 answered