+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Issue with Page Groups not redirecting to default.aspx

Issue with Page Groups not redirecting to default.aspx

5 posts, 0 answered
  1. Christopher
    Christopher avatar
    22 posts
    Registered:
    09 Jun 2008
    01 Oct 2008
    Link to this post
    I have some page groups set up,but I'm having trouble getting them to redirect to a page within that group. So if I type in localhost/TestSite/TestGroup it will give me a 404 error instead of redirecting to default.aspx page. I'm not sure why this is since there is a default.aspx page created inside that group. I noticed that in the more options of the group there is a "Genertated URL" that I can't change and if I add another it doesn't seem to matter. I think this is probably some kind of setting that i need to enable. Any help would be appreciated.

    thanks,
    Chris
  2. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    01 Oct 2008
    Link to this post
    in order to use the page groups as directories, you need to configure your site to use extensionless urls as outline in page 293 on the User Manual found here: http://www.sitefinity.com/support/documentation.aspx.

    however there is a known bug where the redirection will work, but the url will not be correct. this is supposed to be addressed in the update next week. alternatively you can map ALL requests into iis, this is outlined on page 296 of the same manual.

    hope this is helpful!
  3. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    02 Oct 2008
    Link to this post
    Hello guys,

    Josh, you are right. We want to confirm that the bug you described in your post is already fixed.

    Christopher, could you please try browsing your pagegroup with this URL http://localhost/TestSite/TestGroup.aspx and see whether you will receive a 404 Response?

    Regards,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  4. Christopher
    Christopher avatar
    22 posts
    Registered:
    09 Jun 2008
    02 Oct 2008
    Link to this post


    Thanks for the responses. I've tried implementing the solution from the users manual, but I'm getting an error when I try to navigate to the directory.

    Browser Error: "The specified request cannot be executed from current Application Pool"

    I am using a custom app pool not using the default App Pool. I found some info concerning this error which had me altering registry entries which didn't help. Have you seen this before?

    Thanks again,
    Chris
  5. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    06 Oct 2008
    Link to this post
    Hi Christopher,

    Can you please try setting the following in the application web.config:

    <customErrors mode="On">
          <error redirect="~/sf404.aspx" statusCode="404"/>
          <error redirect="~/Sitefinity/nopermissions.aspx" statusCode="403" />
        </customErrors>

    Let us know if the problem still persists.

    Kind regards,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Register for webinar
5 posts, 0 answered