+1-888-365-2779
Try Now
More in this section

Forums / Deployment / new deployment - can't find how to

new deployment - can't find how to

15 posts, 0 answered
  1. Joseph
    Joseph avatar
    10 posts
    Registered:
    30 May 2008
    27 Jan 2009
    Link to this post

    I am looking through the installation and developer's guides for how to deploy a solution from the test (sitefinity native) server to the production webserver, and cannot find it.  Would you please guide me to the info?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    28 Jan 2009
    Link to this post
    Hi Joseph,

    Thank you for using our services.
    Please take a look at our User Manual, section Migrating Projects to the Production Web Server.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. Joseph
    Joseph avatar
    10 posts
    Registered:
    30 May 2008
    28 Jan 2009
    Link to this post
    Beautiful - I knew it had to be documented somewhere, and must have overlooked it somehow.


    I am now getting this error.  I note the docs say I do not have to actually copy SiteFinity to the production server, but it complaining about not having the framework.

    Joe




    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'Telerik.Framework, Version=3.5.1747.2, Culture=neutral, PublicKeyToken=dfeaee0e3978ac79' or one of its dependencies. Access is denied.

    Source Error:

    Line 131:      </eventMappings>
    Line 132:      <providers>
    Line 133: <add name="Simple Web Event Provider" type="Telerik.Utilities.TextFileWebEventProvider,Telerik.Framework" logFileName="~/App_Data/sitefinity.log" />Line 134:        <add name="Simple Web Buffered Event Provider" type="Telerik.Utilities.BufferedTextFileWebEventProvider,Telerik.Framework" bufferMode="Notification" logFileName="~/App_Data/sitefinity.log" />
    Line 135:        <add name="Code Benchmark Provider" type="Telerik.Utilities.CodeBenchmarkTextFileProvider,Telerik.Framework" enabled="False" logFileName="~/App_Data/performance.log" />

    Source File: D:\websites\www.voicetext.com\web.config    Line: 133

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Framework' could not be loaded.

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    


    Version Information: Microsoft .NET Framework Version:2.0.50727.3053; ASP.NET Version:2.0.50727.3053
  4. Joseph
    Joseph avatar
    10 posts
    Registered:
    30 May 2008
    28 Jan 2009
    Link to this post
    Additional note: the file Telerik.Framework.dll does exist in the ~/bin subfolder of the application - it copied when I copied the application files.  Changing the permissions so the Network Service user can access it makes no difference.

    Oh - your pubs are out of date . On Page 65 of the User Manual under step 5, it says the ASPNET user.  On Windows2003Server, that user is NETWORK SERVICE.  There is the new ASPNET user for ASP.


    Joe
  5. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    29 Jan 2009
    Link to this post
    Hi Joseph,

    There are two reasons for the error message you are getting:

    Could not load file or assembly 'Telerik.Framework, Version=3.5.1747.2, Culture=neutral, PublicKeyToken=dfeaee0e3978ac79' or one of its dependencies. Access is denied

    NETWORK SERVICE ( or ASPNET) 
    does not have permissions over the whole folder or permission inheritance has not applied for all items in the /bin directory. Could you give full control on the NETWORK SERVICE account.

    The documentation will be updated with 3.6 official release. Thank you for the notice. Let us know if the problem persists.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  6. Joseph
    Joseph avatar
    10 posts
    Registered:
    30 May 2008
    29 Jan 2009
    Link to this post
    You mentioned two reasons, but only gave one - permissions for NETWORK SERVICE user.  That user had full permission for the folder, I checked it again, and I still get the message.  I appreciate your help here, the webserver is working fine otherwise.  But with SiteFinity, I get a big zero.

    Joe

     

    Server Error in '/SiteFinity' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'Telerik.Framework, Version=3.5.1747.2, Culture=neutral, PublicKeyToken=dfeaee0e3978ac79' or one of its dependencies. Access is denied.

    Source Error:

    Line 131:      </eventMappings>
    Line 132:      <providers>
    Line 133: <add name="Simple Web Event Provider" type="Telerik.Utilities.TextFileWebEventProvider,Telerik.Framework" logFileName="~/App_Data/sitefinity.log" />Line 134:        <add name="Simple Web Buffered Event Provider" type="Telerik.Utilities.BufferedTextFileWebEventProvider,Telerik.Framework" bufferMode="Notification" logFileName="~/App_Data/sitefinity.log" />
    Line 135:        <add name="Code Benchmark Provider" type="Telerik.Utilities.CodeBenchmarkTextFileProvider,Telerik.Framework" enabled="False" logFileName="~/App_Data/performance.log" />

    Source File: D:\websites\SiteFinity\web.config    Line: 133

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Framework' could not be loaded.

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    


    Version Information: Microsoft .NET Framework Version:2.0.50727.3053; ASP.NET Version:2.0.50727.3053
  7. Joseph
    Joseph avatar
    10 posts
    Registered:
    30 May 2008
    29 Jan 2009
    Link to this post
    Here is more info.  I'm trying it, over and over, doing something a little different each time.  I appreciate your help in this.

     

    Server Error in '/TestSite' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'Telerik.Framework, Version=3.5.1747.2, Culture=neutral, PublicKeyToken=dfeaee0e3978ac79' or one of its dependencies. Access is denied.

    Source Error:

    Line 131:      </eventMappings>
    Line 132:      <providers>
    Line 133: <add name="Simple Web Event Provider" type="Telerik.Utilities.TextFileWebEventProvider,Telerik.Framework" logFileName="~/App_Data/sitefinity.log" />Line 134:        <add name="Simple Web Buffered Event Provider" type="Telerik.Utilities.BufferedTextFileWebEventProvider,Telerik.Framework" bufferMode="Notification" logFileName="~/App_Data/sitefinity.log" />
    Line 135:        <add name="Code Benchmark Provider" type="Telerik.Utilities.CodeBenchmarkTextFileProvider,Telerik.Framework" enabled="False" logFileName="~/App_Data/performance.log" />

    Source File: D:\websites\TestSite\web.config    Line: 133

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Framework' could not be loaded.

    === Pre-bind state information ===
    LOG: User = NT AUTHORITY\NETWORK SERVICE
    LOG: DisplayName = Telerik.Framework
     (Partial)
    LOG: Appbase = file:///D:/websites/TestSite/
    LOG: Initial PrivatePath = NULL
    Calling assembly : (Unknown).
    ===
    LOG: This bind starts in default load context.
    LOG: Using application configuration file: D:\websites\TestSite\web.config
    LOG: Using host configuration file: \\?\C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet.config
    LOG: Using machine configuration file from C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\config\machine.config.
    LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).
    LOG: Attempting download of new URL file:///D:/websites/TestSite/bin/Telerik.Framework.DLL.
    LOG: Using application configuration file: D:\websites\TestSite\web.config
    LOG: Using host configuration file: \\?\C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet.config
    LOG: Using machine configuration file from C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\config\machine.config.
    LOG: Post-policy reference: Telerik.Framework, Version=3.5.1747.2, Culture=neutral, PublicKeyToken=dfeaee0e3978ac79
    ERR: Failed to complete setup of assembly (hr = 0x80070005). Probing terminated.
    
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    30 Jan 2009
    Link to this post
    Hello Joseph,

    The error message is still related to permssions - Access is denied.
    Asp.Net tries to load the correct assembly, but setting up the assembly fails. Does NETWORK SERVICES user has write permission on the folder %windir%\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET
    Also, you can clear your ASP.NET temp folder and try to run the application again.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  9. Joseph
    Joseph avatar
    10 posts
    Registered:
    30 May 2008
    30 Jan 2009
    Link to this post
    Yes, that was it.  Giving full authority to network service on the framework folder lets it go forward.

    Thanks, you've saved me from a weekend of heavy drinking.

    Joe
  10. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    02 Feb 2009
    Link to this post
    Hello Joseph,

    I am glad to hear that everything is working now. Let us know if there is anything else that we can do for you.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  11. Martin
    Martin avatar
    1 posts
    Registered:
    26 May 2009
    02 Jun 2009
    Link to this post
    I received this error also but the above solutions didn't fix my problem. I extracted some sample code from sitefinity and straight away started getting the error. I pasted the folder structure straight into my project. The solution that I found was;

    Delete my app_code folder
    Recreate it through VS by selecting Add ASP.net folder APP_Code
    Paste source back into new folder

    Very strange but I'm glad that I got it working!
  12. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    02 Jun 2009
    Link to this post
    Hi Martin,

    Thank you for sharing your experience with us. I hope it will help to our community.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  13. NEX
    NEX avatar
    25 posts
    Registered:
    14 Aug 2007
    30 Jun 2009
    Link to this post
    1. Your link is not working.

    2. This information IS ONLY in the version of the user manual on this site.  It is not in the one installed with the software.
  14. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    30 Jun 2009
    Link to this post
    Hello Alfred Pena,

    1. The link has been changed because we migrated our web site to Sitefinity CMS. The new link is http://www.sitefinity.com/support/user-manual.aspx

    I noticed that this article is not included in the manual. We will update it for the forth coming Service pack. I update your Telerik points.

    Greetings,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  15. Joseph
    Joseph avatar
    11 posts
    Registered:
    03 Aug 2010
    22 Jan 2011
    Link to this post
    Hi,

    It's possible you've copied over SVN database files, if you're using Tortoise SVN, to receive these errors. In my case, the folders turned green. In Windows Explorer, right click the folder. Then, go to Tortoise SVN > Export. Remove the folder on the server and replace it with the exported folder. There should be no .svn folder in the project.

    Joseph Anderson
    http://www.jmawebtechnologies.com
Register for webinar
15 posts, 0 answered