+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Poor first page load times

Poor first page load times

4 posts, 0 answered
  1. Ed
    Ed avatar
    5 posts
    Registered:
    10 Aug 2010
    11 Oct 2010
    Link to this post
    I am currently work with the rackspace CloudSites service as a web host for Sitefinity.  I have reviewed and implemented the medium trust hosting modifications.  Most everything works, with the exception of the content management (known issue, search for shared hosting medium trust).  Unfortunately, I have not been able to get an answer from rackspace.com about when they will officially support ASP.Net 4.0 (other than a beta program).

    Anyways on to my issue...  The first time I load a page it can take upto 30 seconds to load a page!  I have read through a bunch of posts about page caching, and even implemented a rackspace ping for each webpage, every 5 minutes.  This didn't do squat, until I set the InMemory cache limit to 295 seconds (web.config).

    Am I missing something?  This seems silly to have the webserver prod itself to reload each page every 5 minutes.  Not to mention resource intensive, and cumbersome to configure.

    Thanks,
    Ed
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    12 Oct 2010
    Link to this post
    Hi Ed,

    From what you are saying it looks like the application pool is not started and the first request initialize it. Another option is that you have some limits on the application pool and it is recycles or it goes to sleep. You might find this post useful Keep your ASP.Net websites warm and fast 24/7

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Ed
    Ed avatar
    5 posts
    Registered:
    10 Aug 2010
    15 Oct 2010
    Link to this post
    Thank you Ivan, I have read through that article, however on rackspace's cloudsites service I do not have access to install the IIS 7.5 plugin.  On a positive note, rackspace's technical support has provided information on how to grant write access to the IIS web user.

    "Because of the way that IIS is ran on our servers, the IIS user is assigned to the "Group" permissions in our system.  So without having Write permissions on the "Group" for that directory, the application was unable to write the correct file.
    
    
    You can actually modify these permissions yourself by using an FTP client such as FileZilla."
    
    
    This change has fixed an issue with search tool, and has cleared some errors with posting updates via the CMS as well. 

    Do you know if this change will sufficient to re-enable workflow?
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Oct 2010
    Link to this post
    Hi Ed,

    Workflow requires full trust permissions set from the server, because we use reflection. As for the issue with page response, I cannot tell you whether the changes you have made will fix it. There are some settings on your server that slow down the first response and generally the problem is related to the application pool idle timeout.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
4 posts, 0 answered