+1-888-365-2779
Try Now
More in this section

Forums / Deployment / sub .net application error

sub .net application error

13 posts, 0 answered
  1. Nick
    Nick avatar
    14 posts
    Registered:
    30 Jun 2006
    09 Nov 2007
    Link to this post
    I have recently deployed a sitefinity site which has replaced an existing website.  The problem i am having is that the site has another .net application running in a virtual directory under the same domain which now has an error relating to sitefinity.  The error is below, i am wondering if there are any settings that i can change to get this to work.

    Parser Error Message: Could not load file or assembly 'Telerik.Framework' or one of its dependencies. The system cannot find the file specified.

    Source Error:

    Line 89: 			</eventMappings>
    Line 90: 			<providers>
    Line 91: 				<add name="Simple Web Event Provider" type="Telerik.Utilities.TextFileWebEventProvider,Telerik.Framework" logFileName="~/App_Data/sitefinity.log"/>
    Line 92: 				<add name="Simple Web Buffered Event Provider" type="Telerik.Utilities.BufferedTextFileWebEventProvider,Telerik.Framework" bufferMode="Notification" logFileName="~/App_Data/sitefinity.log"/>
    Line 93: 			</providers>
  2. Vlad
    Vlad avatar
    498 posts
    Registered:
    15 Jul 2016
    12 Nov 2007
    Link to this post
    Hello Nick,

    The exception you are getting is caused by the inheritance of configuration files in the application hierarchy. Settings are overriden for subfolders, however, collections set in the web.config files are not overriden but extended as new items are added. To solve this, you have to clear these collections in the web.config in your sub application.

    Add the following sections to the web.config => <system.web>:
    <healthMonitoring>    
      <eventMappings>    
        <clear/>    
      </eventMappings>    
      <providers>    
        <clear/>    
      </providers>    
      <rules>    
        <clear/>    
      </rules>    
    </healthMonitoring>    
     

    Also add a clear tag in the roleManager section:
    <roleManager ...> 
      <providers> 
        <clear/> 
      </providers> 
    </roleManager> 


    You should also add a remove tag to the <httpModules> section, before the add tags:
     
    <httpModules> 
      <remove name="Cms"/>  
    ... 

    and in the <httpHandlers> :

    <httpHandlers> 
      <remove path="*.rss" verb="*"/>  
    ... 

    This should be enough for your application not to seek for .dll files from Sitefinity.
    Hope this will help.

    Sincerely yours,
    Vlad
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Mark Rowe
    Mark Rowe avatar
    2 posts
    Registered:
    20 Sep 2007
    09 Jul 2008
    Link to this post
    Hello,

    I ran into this problem also, and this post helped me fix my sub-application problem...however, with 3.2 there were a few more lines that needed to be added to the web.config under the <httpHandlers> section

        <remove path="*.rss" verb="*"/>  
        <remove path="*.sflb" verb="GET"/> 
        <remove path="*.tmb" verb="GET"/> 
        <remove path="CaptchaImage.axd" verb="GET"/> 
        <remove path="blogs/metablog.ashx" verb="POST"/> 
        <remove path="trackback.ashx" verb="POST"/> 

  4. Vlad
    Vlad avatar
    498 posts
    Registered:
    15 Jul 2016
    10 Jul 2008
    Link to this post
    Hello Bob Erwin,

    Thank you for the supplement.
    The solution was for Sitefinity 3.1. You completed it for 3.2 now.

    All the best,
    Vlad
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  5. Mathieu
    Mathieu avatar
    3 posts
    Registered:
    04 Aug 2008
    24 Sep 2008
    Link to this post
    I've done all the suggested steps but now I stuck with this error:

    Compilation Error

    Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

    Compiler Error Message: BC30002: Type 'ProfileCommon' is not defined.

    Source Error:

    [No relevant source lines]

    Source File: C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\bq2008\ce5974ab\f7789d9e\App_Web_masterpage.master.cdcab7d2.gmlqocfh.0.vb    Line: 57

    What is this?
  6. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    24 Sep 2008
    Link to this post
    you need to also disable role manager for this application:

    <roleManager enabled="false"/> 

    disabling health monitoring might also be necessary:

    <healthMonitoring enabled="false"/> 

    hope this was helpful!
  7. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    24 Sep 2008
    Link to this post
    sorry I meant to say disable the PROFILE provider sorry!

    <profile enabled="false" /> 
  8. Mathieu
    Mathieu avatar
    3 posts
    Registered:
    04 Aug 2008
    24 Sep 2008
    Link to this post
    Thanks SelArom, <profile enabled="false" /> did the trick!
  9. Christo
    Christo avatar
    10 posts
    Registered:
    29 Sep 2008
    11 Dec 2008
    Link to this post
    Hi

    I've also been having this problem, however, after applying all the aforementioned setting to the nested apps .config file, i still get the following error

    Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.

    Source Error:

    Line 16: 	<system.web>		
    Line 17:
    Line 18: <healthMonitoring enabled="false">
    Line 19: <eventMappings>
    Line 20: <clear/>

  10. Christo
    Christo avatar
    10 posts
    Registered:
    29 Sep 2008
    11 Dec 2008
    Link to this post
    before i add in the <clear/> tags, i get errors saying that the types associated with my pages cannot be loaded.

    Parser Error Message: Could not load type 'BingoWeb.Login'.

    Source Error:

    Line 1:  <%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Login.aspx.cs" Inherits="BingoWeb.Login" %>

  11. Georgi
    Georgi avatar
    3583 posts
    Registered:
    20 Sep 2016
    12 Dec 2008
    Link to this post
    Hello Christo,

    Please refer to the article How to disable web.config Inheritance for Child Applications in Subfolders in ASP.NET?, I believe it would help you. Please pay attention to the line:
    <location path="." inheritInChildApplications="false">
    As it is the key to stop the inheritance.

    I hope this helps.

    Kind regards,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  12. Bachar Zeidan
    Bachar Zeidan avatar
    67 posts
    Registered:
    01 Jul 2010
    24 Feb 2011
    Link to this post
    Hi, it happens something strange.
    For external reasons, there was not enough space on the disk where a site of mine is hosted, when the following exception occurred:
    Unable to cast object of type 'ProfileCommon' to type 'ProfileCommon'.
    on this instruction:
    Dim userProfile As ProfileCommon = CType(HttpContext.Current.Profile, ProfileCommon)

    I tried to restart IIS and modify the web.config to force the app pool recycle, but nothing works.
    Finally, I tried to disable
    <profile enabled="false" />
    and then re-enable the profile, and now the website works like a charm.

    What's happens?
  13. Georgi
    Georgi avatar
    3583 posts
    Registered:
    20 Sep 2016
    28 Feb 2011
    Link to this post
    Hello Bachar,

    Unfortunately we are not sure what have caused this behavior. We are using the default Asp.Net 2.0 implementation there. I saw other people having this problem as well - http://w3ka.blogspot.com/2007/03/aspnet-exception-details.html

    Please let us know if you find more information related to the issue.

    Kind regards,
    Georgi
    the Telerik team
    Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!
Register for webinar
13 posts, 0 answered