+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Turkish characters and URLs

Turkish characters and URLs

6 posts, 0 answered
  1. kurtcebe kirecci
    kurtcebe kirecci avatar
    4 posts
    Registered:
    04 May 2005
    01 Mar 2006
    Link to this post
    When we try to create a new page (in edit mode) using a turkish keyboard we can not write the letter i, but we can write the letter ı ( i without point ).
    With the english keyboard we can write i.

    There is another problem related with turkish chracters.
    If we have a page named "lili" and we write navigate to "lili.aspx" we see the page with no problem, but if we write "LILI.aspx" we receive an error.
    On every normal IIS site (asp.net or not) "LILI.aspx" would return the correct page.

    I should warn you that unlike the english alfabet the uppercase of "i" is "İ" and the uppercase of "ı" is "I".
    So I think this last problem is related with Sitefinity searching pages using String.ToUpper() with the turkish locale instead of english locale (and english is the correct one to use for URLs).

    Thanks

  2. Vassil Daskalov
    Vassil Daskalov avatar
    261 posts
    Registered:
    18 May 2013
    02 Mar 2006
    Link to this post
    Hello kurtcebe,

    You must always write your page names in english. URLs don't recognize other language than english.

    About the problem when you have "lili.aspx" and navigate to "LILI.aspx" - there shouldn't be any problems if the page name is in english, rather than turkish.

    Have a nice day,
    Vassil Daskalov
    the telerik team
  3. kurtcebe kirecci
    kurtcebe kirecci avatar
    4 posts
    Registered:
    04 May 2005
    06 Mar 2006
    Link to this post
    Let me focus on the first problem.
    I understand that URLs should allways be written in english characters and I understand you created a form that is supposed to only accept these characters.
    But the problem is that the form doesn't work correctly when you use a turkish keyboard. You can not insert the letter i.
    Since we are turkish and we use turkish keyboards we have a hard time creating new pages because we must go into windows keyboard configuration yo emulate an english keyboard in order to insert a character that we could perfectly write with a turkish keyboard.

  4. Vassil Petev
    Vassil Petev avatar
    48 posts
    Registered:
    30 Nov 2016
    06 Mar 2006
    Link to this post
    Well kurtcebe, this is the problem we face as well, being in Bulgaria. We regret to say that the world wide web was not created in our favor and we should type all URLs in english (at least for now). We agree with you that this is not convenient but we are not sure that we can help.

    Nevertheless, we will research our options.

    All the best,
    Robert
    the telerik team
  5. kurtcebe kirecci
    kurtcebe kirecci avatar
    4 posts
    Registered:
    04 May 2005
    07 Mar 2006
    Link to this post
    Let me just make clear that my intention is to write english characters on the New Page Form.

    Thank you for your attention
  6. Vassil Daskalov
    Vassil Daskalov avatar
    261 posts
    Registered:
    18 May 2013
    07 Mar 2006
    Link to this post
    Hello kurtcebe,

    I guess you want to write your page names in English but don't want to switch every time from Turkish layout to English. If so, we are not sure that the inserted characters will be with the necessary ASCII code when writing the names with the Turkish layout, even if 'e' in Turkish is 'e' in English. When you write your page names with the Turkish layout you are also not allowed to write symbols like [ ] ; ' , . / ` and so on.

    For this reason, as well as for the reasons already mentioned previously, we have a constraint to write page names in English only, without using the above characters. Due to this constraint, you can not write 'i' with the turkish layout (nor with any other layout) in the page name text box.

    The only and most trustworthy way is to write your names with the English layout. We are deeply sorry for this restriction.

    Greetings,

    Robert
    the telerik team
6 posts, 0 answered