+1-888-365-2779
Try Now
More in this section

Forums / Designing & Styling / Responsive Design not working

Responsive Design not working

3 posts, 0 answered
  1. Tuulikki
    Tuulikki avatar
    5 posts
    Registered:
    25 Jan 2013
    22 Mar 2013
    Link to this post
    I'm having a problem with SiteFinity 5.1. Responsive Design controls. I have created a group of rules (for mobile devices) and applied the behavior to transform the layout. My group of rules is active, but when I preview my pages, nothing happens. It doesn't matter whether I try to use "preview for smartphones and tablets" or just resize the window. It also makes no difference whether I try to use specific css file or fine tuning of default layout elements. I tried to follow the steps in SiteFinity Designer's guide but clearly I'm doing something wrong...

    If you can help me, thank you in advance! 

    Edit: Fixed the problem. Probably just something with cache. 
  2. Rico
    Rico avatar
    88 posts
    Registered:
    30 Aug 2012
    18 Jul 2013 in reply to Tuulikki
    Link to this post
    Hi There,
    Could you please elaborate on how you fixed this? I seem to be having the same issue. I've created a 'smartphones' rule that specifies to redirect to a specific page, but as you pointed out the 'preview' renders the content in the original page (and not the page that it was supposed to redirect to).... I'm using the standard layout design (100%) so nothing fancy going on to cause issues (as I believe you can't use custom layouts through .master pages)...

    Thanks!
  3. Tuulikki
    Tuulikki avatar
    5 posts
    Registered:
    25 Jan 2013
    23 Aug 2013 in reply to Rico
    Link to this post
    Hi,

    It seems my problem was as simple as not emptying the cache. Also, I've noticed that sometimes the preview functionality doesn't work as supposed and you have to publish the page to make the changes visible.
3 posts, 0 answered