Try Now
More in this section

Forums / Designing & Styling / Theme not applying on live site, only in design view

Theme not applying on live site, only in design view

4 posts, 0 answered
  1. Jurgen
    Jurgen avatar
    11 posts
    11 Oct 2011
    01 May 2015
    Link to this post


     I have created a custom theme and applied it to a page template, when I'm editing a page using the template I can see my theme is included (the styling is correct) but when I publish my page the theme is not included in the live site (no theme css in the head etc.)


    It seems like this is some sort of bug, can anyone help me with this?

    I have tried to recreate the page, template and theme but it doesn't seem to help.

  2. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    21 Oct 2016
    06 May 2015
    Link to this post
    Hello Jurgen,

    We have replied in the ticket you have opened for this and I am pasting the reply for your convenience here as well:

    The behaviour is strange as registering the theme as Frontend theme as per the article should be fine.

    In addition, in order to replicate the scenario - are you using a Master page or template created with layout editor. Do you have the same behaviour when just create a new page with build-in Page template and add the theme (without any widgets and other resources).

    Furthermore, when you load your page on the frontend, do you have any errors in the browser console? Note that Sitefinity 8.0 uses jQuery 1.11.2, which could conflict with some of the other resources loaded.

    Sabrie Nedzhip
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
  3. Jurgen
    Jurgen avatar
    11 posts
    11 Oct 2011
    08 May 2015
    Link to this post

    Hi Sabrie,

    I have resolved the issue.

    I was creating a page template with the bootstrap template (project feather) when the issue occured. I have recreated the template, this time I copied the bootstrap layout view and used that as my master template. No idea how this solved the issue.

  4. Jennifer
    Jennifer avatar
    0 posts
    27 Nov 2015
    10 Aug in reply to Sabrie Nedzhip
    Link to this post


    Is there a way to get a registered Sitefinity theme applied to the MVC templates? I'd like to use a Sitefinity theme applied to a bootstrap template. I'm currently having the same trouble, the theme is applied in design view, but not the preview or live version of the page template, or any subsequent pages created from that template. 



4 posts, 0 answered