+1-888-365-2779
Try Now
More in this section

Forums / Designing with Sitefinity / Custom Skin IE7 Issue

Custom Skin IE7 Issue

2 posts, 0 answered
  1. John Colclough
    John Colclough avatar
    7 posts
    Registered:
    05 Nov 2009
    31 Aug 2010
    Link to this post
    Hi everyone, I'm hoping someone can help with a rendering issue I am seeing in IE7. I have attached an image which shows the problem.

    I've created a custom skin using the visual style builder and I'm seeing the menu how I would expect in IE8 and Firefox but IE7 is picking up a class that no matter what I do, I do not seem to be able to get rid of it. The offending class in the custom css file is as follows;

    .RadMenu_CnxDefault ul.rmRootGroup,
    .RadMenu_CnxDefault div.rmRootGroup
    {
     padding: 1px 0;
     border: 1px solid #7c7c7c;
     background-color: #e4e4e4;
    }

    I've set EnableEmbeddedSkins equal to false, I've set the Skin name to the custom name and the menu itself is very simple being placed in a usercontrol and having a static rather than bound format, see below;

    <telerik:RadMenu ID="RadMenu1" EnableEmbeddedSkins="false" Skin="CnxDefault" runat="server" OnClientItemOpened="itemOpened" Width="960px" Height="47px" ExpandAnimation-Type="InOutQuart" CollapseAnimation-Type="InOutQuart">
        <Items>
            <telerik:RadMenuItem Text="Young People" NavigateUrl="#"></telerik:RadMenuItem>
            <telerik:RadMenuItem Text="Page2" NavigateUrl="#"></telerik:RadMenuItem>
            <telerik:RadMenuItem Text="Page3" NavigateUrl="#"></telerik:RadMenuItem>
     <telerik:RadMenuItem Text="Page4" NavigateUrl="#"></telerik:RadMenuItem>
     <telerik:RadMenuItem Text="Page5" NavigateUrl="#"></telerik:RadMenuItem>
     <telerik:RadMenuItem Text="Page6" NavigateUrl="#"></telerik:RadMenuItem>
     <telerik:RadMenuItem Text="Page7" NavigateUrl="#"></telerik:RadMenuItem>
     <telerik:RadMenuItem Text="Page8" NavigateUrl="#"></telerik:RadMenuItem>
        </Items>
    </telerik:RadMenu>

    I've cleared my cache, I've commented the class out and adjusted the class to be invisible and all to no avail, the visual style builder custom skin has the same name as my theme and it is how the menu skin is being applied, I've used the IE developer toolbar colour picker to determine that the background of the horrible block in the IE7 menu is e4e4e4 and the border is 7c7c7c, it has to be that class yes?

    What am I doing wrong guys/gals? Your input would be greatly appreciated,

    kind regards,
    John C.
  2. John Colclough
    John Colclough avatar
    7 posts
    Registered:
    05 Nov 2009
    31 Aug 2010
    Link to this post
    I've fixed this IE7 issue now. I have no explanation of why the class was showing the colours that it contained because I was setting virtually all borders and backgrounds to transparent in the visual style builder, anyway editing the css has now yielded some results and is looking good in IE7 too.

    I had emptied the temporary asp.net folder, cleared the cache and done an iis reset and I could not get rid of it this morning but now all is good, just one of those weird "doesn't work one minute" , "does the next" programming issues, either that or I'm going mad :-{

    regards,
    John C.
2 posts, 0 answered