Try Now
More in this section

Forums / Designing with Sitefinity / Error while setting SiteMenu control properties

Error while setting SiteMenu control properties

3 posts, 0 answered
  1. Jay Mehta
    Jay Mehta avatar
    28 posts
    30 Jun 2009
    10 Aug 2009
    Link to this post

    I am using a SiteMenu control in my template. It works fine, if I do not apply any css class to it. As soon as I apply css class, it gives me an error while previewing or publishing it.  It displays ok in the edit mode.

    Can any one guide me on this, am I doing something wrong?

    Thank you,
    Jay Mehta.
  2. Shannaka Beveridge
    Shannaka Beveridge avatar
    8 posts
    09 Aug 2009
    11 Aug 2009
    Link to this post
    Hi Jay,

    I'm new to Sitefinity myself but I've just spent the morning customising my menu. I haven't tried adding a css class to mine but have used the css classes that are already applied:

    ul.rmRootGroup for parent ul
    ul.rmGroup for child ul
    li.rmItem for li
    li.rmFirst for first li in list
    li.rmLast for last li in list
    a.rmLink for link
    a.selectedItem for selected

    Hope this helps. If it doesn't, come back and post the exact error and I'm sure someone else will be able to give you a hand.

  3. Nikolai
    Nikolai avatar
    216 posts
    21 Oct 2016
    11 Aug 2009
    Link to this post
    Hi Shannaka Beveridge,

    The SiteMenu control is wrapper of the RadMenu control and the reason for these skin changes is that the theme is taken from "~AppThemes\[one of the default themes]\RadMenu.skin".If you delete this file the RadMenu will use its internal skins in that theme mode.

    Hope this helps.

    All the best,
    the Telerik team

    Instantly find answers to your questions on the newTelerik Support Portal.
    Check out the tipsfor optimizing your support resource searches.
Register for webinar
3 posts, 0 answered