+1-888-365-2779
Try Now
More in this section

Forums / Designing with Sitefinity / Innter Master of Company theme throws error

Innter Master of Company theme throws error

16 posts, 0 answered
  1. Jörg Lang
    Jörg Lang avatar
    4 posts
    Registered:
    11 Apr 2006
    28 Oct 2008
    Link to this post
    I just downloaded the community edition 3.5 an started with a new project that uses the Company template. However the inner master page throws an error in the Admin part of Sitefinity.

    Does anyone know what is wrong?
  2. Pepi
    Pepi avatar
    981 posts
    Registered:
    08 Dec 2016
    28 Oct 2008
    Link to this post
    Hi Jörg,

    Unfortunately, we cannot reproduce any problem locally. Please provide the exact error message so that we can investigate the problem. Also, what browser do you use and what version?

    Thanks for your cooperation in advance.

    Regards,
    Pepi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. Jörg Lang
    Jörg Lang avatar
    4 posts
    Registered:
    11 Apr 2006
    28 Oct 2008
    Link to this post
    Sorry I forgot to post the error message in my initial posting. Below you see the message. I did not change anything it was like this when I installed it out of the box. 

    Jörg

     

    Server Error in '/' Application.

    Object reference not set to an instance of an object.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [NullReferenceException: Object reference not set to an instance of an object.]
       Telerik.Cms.Web.CmsSiteMapProvider.CacheNodes(SiteMapNode parentNode) +250
       Telerik.Cms.Web.CmsSiteMapProvider.GetChildNodes(SiteMapNode parentNode) +79
       System.Web.SiteMapNode.get_ChildNodes() +23
       System.Web.UI.WebControls.SiteMapDataSource.GetNodes() +624
       System.Web.UI.WebControls.SiteMapDataSource.GetTreeView(String viewPath) +32
       System.Web.UI.WebControls.SiteMapDataSource.GetHierarchicalView(String viewPath) +29
       System.Web.UI.HierarchicalDataSourceControl.System.Web.UI.IHierarchicalDataSource.GetHierarchicalView(String viewPath) +7
       Telerik.RadPanelbarUtils.RadControlDataSource.System.Web.UI.IHierarchicalDataSource.GetHierarchicalView(String viewPath) +10
       Telerik.WebControls.RadPanelbar.PerformDataBinding(IEnumerable data) +669
       System.Web.UI.WebControls.DataBoundControl.OnDataSourceViewSelectCallback(IEnumerable data) +111
       System.Web.UI.DataSourceView.Select(DataSourceSelectArguments arguments, DataSourceViewSelectCallback callback) +29
       System.Web.UI.WebControls.DataBoundControl.PerformSelect() +149
       System.Web.UI.WebControls.BaseDataBoundControl.DataBind() +70
       System.Web.UI.WebControls.BaseDataBoundControl.EnsureDataBound() +82
       System.Web.UI.WebControls.BaseDataBoundControl.OnPreRender(EventArgs e) +19
       Telerik.WebControls.RadPanelbar.OnPreRender(EventArgs e) +52
       System.Web.UI.Control.PreRenderRecursiveInternal() +86
       System.Web.UI.Control.PreRenderRecursiveInternal() +170
       System.Web.UI.Control.PreRenderRecursiveInternal() +170
       System.Web.UI.Control.PreRenderRecursiveInternal() +170
       System.Web.UI.Control.PreRenderRecursiveInternal() +170
       System.Web.UI.Control.PreRenderRecursiveInternal() +170
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2041
    


    Version Information: Microsoft .NET Framework Version:2.0.50727.1434; ASP.NET Version:2.0.50727.1434
  4. Pepi
    Pepi avatar
    981 posts
    Registered:
    08 Dec 2016
    29 Oct 2008
    Link to this post
    Hi Jörg,

    This is a known issue related to a bug in CmsSitemapProvider. The problem will be fixed in the upcoming SP.

    We are sorry for the inconvenience caused.

    Best wishes,
    Pepi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  5. Chad
    Chad avatar
    9 posts
    Registered:
    04 Oct 2012
    03 Nov 2008
    Link to this post
    Can anyone confirm that this was fixed in SP1? I am still having the issue.
  6. Pepi
    Pepi avatar
    981 posts
    Registered:
    08 Dec 2016
    04 Nov 2008
    Link to this post
    Hi Dustin,

    We confirm that the issue is fixed in v3.5 SP1. If the problem still persists please give us more details to localize what is wrong:
    1. Steps to reproduce
    2. Do you replicate the problem with a brand new project or with an upgraded one?
    3. Stack trace of the error

    Thanks for your cooperation in advance.

    Best wishes,
    Pepi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  7. Chad
    Chad avatar
    9 posts
    Registered:
    04 Oct 2012
    04 Nov 2008
    Link to this post
    I am sorry, as I was going through the steps to write my response, it now suddenly works. Not sure what was going on or what, but i spent 5 hours yesterday trying it get it to work. If I have the trouble again I will replay back. Thanks.
  8. Jörg Lang
    Jörg Lang avatar
    4 posts
    Registered:
    11 Apr 2006
    04 Nov 2008
    Link to this post
    Sorry, but I have initially reported this error for the SP1. So it is certainly not fixed for my computer.

    Regards
    Jörg
  9. Chad
    Chad avatar
    9 posts
    Registered:
    04 Oct 2012
    04 Nov 2008
    Link to this post
    Have you upgraded to SP1? Are you running it as a web application or web site? Have you upgraded it to .net 2.0 or 3.5?
  10. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    04 Nov 2008
    Link to this post
    Hello Jörg Lang,

    SP1 was released in the late hours of 29 October, 2008, while your initial request was sent on Date: 10/28/2008 8:31:26 AM. At this time, SP1 was not uploaded.

    Could you please tell us which version exactly you use? You may follow the Kb Article How to check your current Sitefinity version?.

    We have already received confirmation from other community members that SP1 actually fixed the error.

    Please follow-up with the details we asked about so we could manage to take further actions in solving the problem.

    Sincerely yours,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  11. Jörg Lang
    Jörg Lang avatar
    4 posts
    Registered:
    11 Apr 2006
    04 Nov 2008
    Link to this post
    OK then I am mistaken. I actually thought the version I downloaded already said it was SP1. But it seems not to be...
  12. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    04 Nov 2008
    Link to this post
    Hi Jörg Lang,

    You should have no problems after upgrading. Here are the Upgrade Instructions.
    Let us know if you experience any problems with the upgrade.

    Kind regards,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  13. Zubair
    Zubair avatar
    142 posts
    Registered:
    26 Dec 2007
    30 Dec 2008
    Link to this post
    hello,

    I'm using Sitefinity 3.5.1747.2:0 (I think it's SP1?) and most of the pages I have in the CMS have suddenly started throwing me the following exception, I noticed this problem after I added Arabic localization in the CMS, note that some other pages dont show this exception. Please tell me what's causing this issue on As Soon as Possible basis because the client is reviewing this site v soon. Thanks

     

    Server Error in '/' Application.

    Object reference not set to an instance of an object.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [NullReferenceException: Object reference not set to an instance of an object.]
       Telerik.Cms.Data.PageContentBase.Telerik.Cms.IPage.get_ContainsUrlSrvc() +52
       Telerik.Cms.Web.CmsSiteMapProvider.AddUrlServices(ICmsPage page, CmsSiteMapNode node, String key) +38
       Telerik.Cms.Web.CmsSiteMapProvider.CacheNode(ICmsPage page, CmsSiteMapNode parentNode) +466
       Telerik.Cms.Web.CmsSiteMapProvider.GetUrlContext(String url, Boolean skipSvcs) +1061
       Telerik.Cms.Web.UrlHelper.GetUrl(String url, Boolean skipSvcs) +44
       Telerik.Cms.Web.CmsHttpModule.BeginRequest(Object sender, EventArgs e) +1159
       System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +92
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +64
    

  14. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    30 Dec 2008
    Link to this post
    Hi Zubair,

    Is it possible to send us your web.config file, the App_Master directory and your project database? You can mail me at georgi.chokov@telerik.com.

    Regards,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  15. Zubair
    Zubair avatar
    142 posts
    Registered:
    26 Dec 2007
    13 Jan 2011
    Link to this post
    Hi,

    We recently localized a website v3.5 SP1 website and this error is back and I cant recall how I fixed it 2 years ago, could you please help me, I error on homepage was removed by duplicating it and removing the old one, however I still get the same error on some other pages. Also there is no navigation that uses CmsSiteMapProvider provider.

    Please help urgently, thanks
  16. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    13 Jan 2011
    Link to this post
    Hello Zubair,

    Please check whether there is  difference for the templates and their ID in the following tables.

    • [sf_CmsPageTemplate]
    • [sf_PageContentBase]
    • [sf_PageBase]  -ItemType - PageTemplate

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
16 posts, 0 answered