+1-888-365-2779
Try Now
More in this section

Forums / Designing with Sitefinity / RadMenu EnableEmbeddedSkins=False Not Working

RadMenu EnableEmbeddedSkins=False Not Working

5 posts, 0 answered
  1. BobTabor
    BobTabor avatar
    17 posts
    Registered:
    12 Dec 2007
    30 Mar 2010
    Link to this post
    Hi, I have two templates created by a Sitefinity MVP who is obviously very familiar with the inner workings of it all.

    My goal was simple: I wanted to create a new template based on one of his templates -- just needed a small change to the body of the template.  In my version of the template, the RadMenu (not related to my changes) is not rendering correctly ... it has a different font, a border defined, a background color, etc.  Looking at Firebug, it seemed that my version of the page is referencing WebResource.axd and his is not.  Somehow, he suppressed the default styles embedded in the RadMenu.  So, after trolling your forums I realized that my new template's RadMenu still had it's EnableEmbeddedSkins and EnableEmbeddedBaseStylesheet set to True while his template's RadMenu had those properties set to false.  GREAT, I thought I had figured it out.

    However, even after I changed those properties to false, I'm still seeing that my new template's RadMenu is pulling style from the WebResource.axd with no change to my new template's output.

    He doesn't have any skins created, and both pages share the same theme.  Also, both pages are sharing the same external CSS file.  I'm completely stumped.  Anywhere else I can look?  What am I missing?

    BTW, this is referencing v. 3.7.

    Thank you!
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    31 Mar 2010
    Link to this post
    Hello BobTabor,

    If the embedded resources are disabled, there should be a skin that styles the control. Here are two useful links : How skins work, Creating custom skins. You can also observer the styles that are applies over the RadMenu on the working website. They could come from some common css classes. Anyhow, the best way to change the appearance of a control is creating a custom Skin for it.

    Greetings,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Jacques
    Jacques avatar
    427 posts
    Registered:
    28 Jun 2007
    19 Jan 2012
    Link to this post
    Hi Ivan,

    We're having a similar problem in SF 4.3 where we've disabled the two embedded attributes, but we're still seeing the webresource file overwriting our custom CSS. We've got our own styles for it and we don't want the extra network traffic for a file that is not being used?

    Why are those two attributes not properly switching off the embedded resources?

    Jacques
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    20 Jan 2012
    Link to this post
    Hi,

    There are embedded resources that are loaded until you remove them explicitly. Please take a look at this article.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Jacques
    Jacques avatar
    427 posts
    Registered:
    28 Jun 2007
    20 Jan 2012
    Link to this post
    Wow, tell me you didn't just give me advice that would break the back end of Sitefinity?

    When I did what you suggested it certainly did what I wanted for the menu on the front end, but it rendered the editing abilities (page editing) broken. On content blocks the edit button was missing, the drop down arrow doesn't do anything, etc.

    I have two problems with where this is going:
    1. You've just given careless advice that breaks Sitefinity
    2. Mapping a given control to a custom template and setting the control's EnableEmbeddedX property to false doesn't work. This has plagued me with Telerik for years. There's always a glitch somewhere along the line. Brilliant ideas, but always glitches everywhere.

    Or am I understanding all of this wrong?

    Jacques
Register for webinar
5 posts, 0 answered