+1-888-365-2779
Try Now
More in this section

Forums / Designing with Sitefinity / Sitefinity template disappearing

Sitefinity template disappearing

7 posts, 0 answered
  1. Ty
    Ty avatar
    4 posts
    Registered:
    23 Jan 2009
    27 May 2010
    Link to this post
    I am creating a new template in Sitefinity (in VS, not via upload), successfully add it to the page, but then am unable to publish.  I already have several other templates in there and working with no issues

    Neither the Cancel changes or Publish buttons work.  I tried following the directions in this thread to no avail.  Restarting IIS and clearing my browser cache sometimes gets it back but not always.

    I have tried going down to a bare bones master page (i.e. no content) with no success.

    I periodically get another error as well, which I think is related to the search indexes - not sure if these two items are related:

    There were errors during services initialization, check the error log for details.

    Server Error in '/' Application.

    There were errors during services initialization, check the error log for details.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Web.HttpException: There were errors during services initialization, check the error log for details.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [HttpException (0x80004005): There were errors during services initialization, check the error log for details.]
       Telerik.Framework.ServiceHost.Initialize() +479
       Telerik.Cms.Web.CmsHttpModule.Init(HttpApplication context) +100
       System.Web.HttpApplication.InitModulesCommon() +65
       System.Web.HttpApplication.InitModules() +43
       System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers) +729
       System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context) +298
       System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context) +107
       System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +289
    
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    27 May 2010
    Link to this post
    Hello Ty,

    Could you clear the sitefinity.log that is located under App_Data folder, then restart the application and access the website. The error you have posted is result of another issue. The actual error should be written in the sitefinity.log file. After you have performed the steps above you could post the content of the sitefinity.log file.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Ty
    Ty avatar
    4 posts
    Registered:
    23 Jan 2009
    27 May 2010
    Link to this post
    Pertinent portion of that contains the following:
    Process information:
        Process ID: 2968
        Process Name: aspnet_wp

    Request information:
        Request URL: /sitefinity/default.aspx
        Rewrite URL: http://localhost/sitefinity/default.aspx
        Url Referrer:    Is Authenticated: False
        Authentication Type:    User:     User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; MS-RTC LM 8)
        User Address: 127.0.0.1

    Variables:

    - L0 -------------------------------------------------------------------------------

    Exception Type: System.ArgumentException

    Message: Invalid indexing client name specified.

    Source: Telerik.Search

    Stack Trace:
       at Telerik.Search.Engine.IndexingService..ctor(IIndexingServiceInfo settings)
       at Telerik.Search.Engine.IndexingManager.Initialize()
       at Telerik.Framework.ServiceHost.Initialize()
    ------------------------------------------------------------------------------------
  4. Ty
    Ty avatar
    4 posts
    Registered:
    23 Jan 2009
    27 May 2010
    Link to this post
    I think the unrelated search thing is resolved (cleared out/rebuilt indexes).

    For the original issue, I don't get a sitefinity.log entry.  However, Clicking publish fires a javascript error:

    Line: 50
    Error: Object doesn't support this property or method

    Debugging this error shows it stopping in the postback method on theForm.submit():

    function __doPostBack(eventTarget, eventArgument) {
        if (!theForm.onsubmit || (theForm.onsubmit() != false)) {
            theForm.__EVENTTARGET.value = eventTarget;
            theForm.__EVENTARGUMENT.value = eventArgument;
            theForm.submit();
        }
  5. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    27 May 2010
    Link to this post
    Hello Ty,

    Check whether the any js library is not loaded properly. You could observe the request with FireBug or Fiddler. Try to use one of the default templates to narrow down whether the issue comes somewhere from your template.

    Greetings,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  6. Jason
    Jason avatar
    17 posts
    Registered:
    15 Oct 2010
    23 Oct 2010
    Link to this post
    i have same error. Basically, i have another instance of sitefinity in the sub folder of the root, here is the log

    Application information:
    Machine name: STATION86
    OS Version: Microsoft Windows NT 6.1.7600.0
    Product Version: 3.7.2136.2
    Application Path: D:\Web Development\Web Sites\www.iolo.com.sitefinity\Labs\
    Debug: False

    Process information:
    Process ID: 5572
    Process Name: w3wp

    Request information:
    Request URL: /Labs/
    Rewrite URL: http://127.0.0.1/Labs/
    Url Referrer: Is Authenticated: False
    Authentication Type: User: User Agent: 
    User Address: 127.0.0.1

    Variables:

    - L0 -------------------------------------------------------------------------------

    Exception Type: System.TypeInitializationException

    Message: The type initializer for 'Telerik.Search.Configuration.ConfigHelper' threw an exception.

    Source: Telerik.Search

    Stack Trace: 
       at Telerik.Search.Configuration.ConfigHelper.get_Handler()
       at Telerik.Search.IndexDataManager.get_ProvidersSettings()
       at Telerik.ManagerBase`1.Initialize()
       at Telerik.ManagerBase`1..ctor(String providerName)
       at Telerik.ManagerBase`1..ctor()
       at Telerik.Search.Engine.IndexingManager.Initialize()
       at Telerik.Framework.ServiceHost.Initialize()
    ------------------------------------------------------------------------------------
    - L1 -------------------------------------------------------------------------------

    Exception Type: System.Configuration.ConfigurationErrorsException

    Message: The entry 'PageIndex' has already been added. (D:\Web Development\Web Sites\www.iolo.com.sitefinity\Labs\web.config line 288)

    Source: System.Configuration

    Stack Trace: 
       at System.Configuration.BaseConfigurationRecord.EvaluateOne(String[] keys, SectionInput input, Boolean isTrusted, FactoryRecord factoryRecord, SectionRecord sectionRecord, Object parentResult)
       at System.Configuration.BaseConfigurationRecord.Evaluate(FactoryRecord factoryRecord, SectionRecord sectionRecord, Object parentResult, Boolean getLkg, Boolean getRuntimeObject, Object& result, Object& resultRuntimeObject)
       at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
       at System.Configuration.BaseConfigurationRecord.GetSection(String configKey, Boolean getLkg, Boolean checkPermission)
       at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
       at System.Web.HttpContext.GetSection(String sectionName)
       at System.Web.Configuration.HttpConfigurationSystem.GetSection(String sectionName)
       at System.Web.Configuration.HttpConfigurationSystem.System.Configuration.Internal.IInternalConfigSystem.GetSection(String configKey)
       at System.Configuration.ConfigurationManager.GetSection(String sectionName)
       at Telerik.Search.Configuration.ConfigHelper..cctor()
    ------------------------------------------------------------------------------------



    10/22/2010 4:16:01 PM [UNKNOWN]
    ************************************************************************************
    ID: f57364d6-080d-4a02-8fd4-e86e9901d1a7; Code: 3005; Occurrence: 1; Sequence: 3
    ------------------------------------------------------------------------------------

    Application information:
    Machine name: STATION86
    OS Version: Microsoft Windows NT 6.1.7600.0
    Product Version: 3.7.2136.2
    Application Path: D:\Web Development\Web Sites\www.iolo.com.sitefinity\Labs\
    Debug: False

    Process information:
    Process ID: 5572
    Process Name: w3wp

    Request information:
    Request URL: /labs/about.aspx
    Rewrite URL: http://localhost:81/labs/about.aspx
    Url Referrer: Is Authenticated: False
    Authentication Type: User: User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
    User Address: ::1

    Variables:

    - L0 -------------------------------------------------------------------------------

    Exception Type: System.Web.HttpException

    Message: There were errors during services initialization, check the error log for details.

    Source: Telerik.Framework

    Stack Trace: 
       at Telerik.Framework.ServiceHost.Initialize()
       at Telerik.Cms.Web.CmsHttpModule.Init(HttpApplication context)
       at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
       at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
       at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
       at System.Web.HttpApplicationFactory.GetPipelineApplicationInstance(IntPtr appContext, HttpContext context)
       at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)
    ------------------------------------------------------------------------------------

    Please let me know what the issues are?

    Thanks,
    Jason
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    24 Oct 2010
    Link to this post
    Hello Jason,

    You have to break the website inheritance of the web.configs


    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
7 posts, 0 answered