+1-888-365-2779
Try Now
More in this section

Forums / Designing with Sitefinity / Templates no longer working

Templates no longer working

4 posts, 0 answered
  1. fregas baratis
    fregas baratis avatar
    185 posts
    Registered:
    14 Nov 2002
    18 Jul 2007
    Link to this post
    After an upgrade from SF RC2 to the full version, all our templates quit working.  Existing pages are fine, but when editing or adding new pages, the contentplaceholders do not show up in the editor.

    I remembered reading in a thread here about nested master pages, you had to delete your old templates, re-upload the new master pages, re-assign the pages to the newly created template, and then the content placeholders whould show up again.  I tried this using a test page, and this worked.  However, we have about 10 templates, most of which use a single master page, and we have dozens of pages using these various templates.  Is there an easier way to fix the contentplaceholdres without having to basically recreate all these templates and reassign all the pages to them?

    I would also stress that there should be a way to edit a template and tell it to use a different master page or update a new master page for that template, without having to delete the template and re-upload.  This way, existing pages coudl work unaffected using the same template but with a different master page.

    Thanks,
    Craig
  2. fregas baratis
    fregas baratis avatar
    185 posts
    Registered:
    14 Nov 2002
    19 Jul 2007
    Link to this post
    Also, is there a way to hide certain contentplacholders?  For instance, when nesting master pages, the parent master page's placeholders show in the editor as well as the inner master page's placeholders.  I only want the inner one's to show.

    Thanks,
    Craig
  3. Pepi
    Pepi avatar
    981 posts
    Registered:
    08 Dec 2016
    20 Jul 2007
    Link to this post
    Hi fregas baratis,

    We will need more time to investigate this issue. We will try to simulate the described behavior and after that we will do our best to figure out some solution. We will contact you right away if we find a workaround.

    Thanks for your patience and understanding.

    Sincerely yours,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  4. Vassil Daskalov
    Vassil Daskalov avatar
    261 posts
    Registered:
    18 May 2013
    23 Jul 2007
    Link to this post
    Hi Craig,

    We were able to test converting from RC2 to SP2 version and did not get any problems with nested masterpages or any data. The automatic upgrade did not mess up anything. So we think, it would be most convenient if you could send us your project. We can do the upgrade for you. In case you have only the upgraded version, we would like to take a look at it and see what we can do about it.

    About your content placeholders preferences, it would be impossible to hide the parents' placeholders as they should be visible in case you want to put some control in them. Unfortunately, we are not able to come up with any solution for showing only the children ones.

    Thanks in advance.

    Best wishes,
    Vassil Daskalov
    the Telerik team 

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
4 posts, 0 answered