+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / 6-1 SP2 Module Builder Problems - Anyone having this?

6-1 SP2 Module Builder Problems - Anyone having this?

6 posts, 0 answered
  1. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    21 Sep 2013
    Link to this post
    I upgraded a site to 6.1 SP2 and now have some problems with the module builder (ticket open)

    Now I have a fresh 6.1 SP2 installation and when I tried to add my first content in modules upon saving it just turned and turned and turned (blue bars indicating something is doing something)

    Now when I go to content my module the same thing. can't access this and blue bars showhing.

    If I remember correct I had that about a year ago but can't find thread. Anyone else with problems with module builder in 6.1 SP2 or has had this happen and remember how he/she fixed it.

    Markus
  2. Ivan D. Dimitrov
    Ivan D. Dimitrov avatar
    310 posts
    Registered:
    26 Mar 2015
    26 Sep 2013
    Link to this post
    Hello Markus,

    The loading time not finishing behavior is connected with a Sitefinity service either not found or not initialized properly. Can you please inspect the page and see which one is making problems. After that make sure that you have it in your web.config or in the Project\Sitefinity\Services folder. Could you please send us screenshots of the Console and Network Tab to see the error itself. You could provide us with backend credentials and a link to your web site in the support ticket to investigate the behavior deeply.

    Regards,
    Ivan D. Dimitrov
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    26 Sep 2013 in reply to Ivan D. Dimitrov
    Link to this post
    Dear Ivan 

    Thank's for comming back.

    QUOTE
    I upgraded a site to 6.1 SP2 and now have some problems with the module builder (ticket open)
    UNQUOTE

    Everything has been provided. PD has the project.

    Markus
  4. Ivan D. Dimitrov
    Ivan D. Dimitrov avatar
    310 posts
    Registered:
    26 Mar 2015
    28 Sep 2013
    Link to this post
    Hi Markus,

     The ticket has been assigned to me. I am currently working on it. Please refer to it for further information, and you could share its outcome with the community afterwards.

    Regards,
    Ivan D. Dimitrov
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    30 Sep 2013 in reply to Ivan D. Dimitrov
    Link to this post
    Dear Ivan

    Thank's for the help. For the community here is what Telerik support has found out :-)

     The problem you
    are facing is caused by the fact that our Module builder fails to translate the
    URL from 

    http://localhost:60876/Sitefinity/Administration/Modul-Generator/module/type/d6aad405-02e3-6713-8867-ff0000103799

    to

    http://localhost:60876/Sitefinity/Administration/Modul-Generator/Modul/Typ/d6aad405-02e3-6713-8867-ff0000103799



    You were right all along - this is a bug and I have logged it accordingly. You
    can vote to raise its priority on our PITS. 

    Additionally - any
    steps taken in producing this behavior concerning the deployment of the
    language pack will be highly appreciated.



     The only workaround I can suggest is to not to translate these two words
    that cause the issue - Module and Type - from Labels & Messages. For more information on how
    to do that please click here.






    Once again it seems to be multilingual related in my case. Might be for other the same or a totally other reason.

    Markus



  6. UI Crew
    UI Crew avatar
    151 posts
    Registered:
    27 Sep 2012
    10 Oct 2013 in reply to Markus
    Link to this post
    Hi,

    I have a similar problem - since installing 6.1 SP2 I have had trouble activating and deactivating modules. When the site first ran after the upgrade some modules (eg. news and forms) failed to initiailise and now just have "Failed" - if I try to install them the website just says "system restarting" and never comes back until I refresh the app pool.

     If I use the module builder I get a red error message when I try to activate the module and then when I go to another page after that the website displays the "system restarting" which it never recovers from.

    Here is the error:

    ----------------------------------------
    Timestamp: 10/10/2013 4:35:29 AM
    Message: HandlingInstanceID: e4cee50c-b25f-451b-8ccd-59be0592ecd1
    An exception of type 'Telerik.Microsoft.Practices.Unity.ResolutionFailedException' occurred and was caught.
    -----------------------------------------------------------------------------------------------------------
    10/10/2013 14:35:29
    Type : Telerik.Microsoft.Practices.Unity.ResolutionFailedException, Telerik.Sitefinity.Utilities, Version=6.1.4700.0, Culture=neutral, PublicKeyToken=b28c218413bdf563
    Message : Resolution of the dependency failed, type = "Telerik.Sitefinity.DynamicModules.Builder.ModuleBuilderManager", name = "OPENACCESSPROVIDER".
    Exception occurred while: while resolving.
    Exception is: InvalidOperationException - The type String cannot be constructed. You must configure the container to supply this value.
    -----------------------------------------------
    At the time of the exception, the container was:

      Resolving Telerik.Sitefinity.DynamicModules.Builder.ModuleBuilderManager,OPENACCESSPROVIDER
      Resolving parameter "providerName" of constructor Telerik.Sitefinity.DynamicModules.Builder.ModuleBuilderManager(System.String providerName, System.String transactionName)
        Resolving System.String,(none)

    Source : Telerik.Sitefinity.Utilities
    Help link : 
    TypeRequested : ModuleBuilderManager
    NameRequested : OPENACCESSPROVIDER
    Data : System.Collections.ListDictionaryInternal
    TargetSite : System.Object DoBuildUp(System.Type, System.Object, System.String, System.Collections.Generic.IEnumerable`1[Telerik.Microsoft.Practices.Unity.ResolverOverride])
    HResult : -2146233088
    Stack Trace :    at Telerik.Microsoft.Practices.Unity.UnityContainer.DoBuildUp(Type t, Object existing, String name, IEnumerable`1 resolverOverrides)
       at Telerik.Microsoft.Practices.Unity.UnityContainer.DoBuildUp(Type t, String name, IEnumerable`1 resolverOverrides)
       at Telerik.Microsoft.Practices.Unity.UnityContainerExtensions.Resolve[T](IUnityContainer container, String name, ResolverOverride[] overrides)
       at Telerik.Sitefinity.Data.ManagerBase`1.GetManager[T](String providerName, String transactionName)
       at Telerik.Sitefinity.DynamicModules.Builder.ModuleBuilderModule.Load()
       at Telerik.Sitefinity.Services.SystemManager.InitializeModule(ModuleSettings settings, InstallContext installContext, Nullable`1 start, Boolean skipLoading)
       at Telerik.Sitefinity.Services.SystemManager.Initialize()
       at Telerik.Sitefinity.Abstractions.Bootstrapper.RegisterRoutes()
       at Telerik.Sitefinity.Abstractions.Bootstrapper.Bootstrap()
       at Telerik.Sitefinity.Services.SystemManager.RestartApplication(Boolean attemptFullRestart, Boolean sendRestartApplicationSystemMessage)
       at Telerik.Sitefinity.DynamicModules.Builder.Install.ModuleInstaller.UninstallModule(DynamicModule module, Boolean commitTransaction)
       at Telerik.Sitefinity.DynamicModules.Builder.Web.Services.ContentTypeService.DeactivateContentTypeInternal(String moduleId, String providerName)
       at SyncInvokeDeactivateModule(Object , Object[] , Object[] )
       at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
       at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)
       at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)
       at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc)
       at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)

    Additional Info:

    MachineName : AMAZONA-NT94267
    TimeStamp : 10/10/2013 4:35:29 AM
    FullName : Telerik.Sitefinity.Utilities, Version=6.1.4700.0, Culture=neutral, PublicKeyToken=b28c218413bdf563
    AppDomainName : /LM/W3SVC/9/ROOT-1-130258522154564135
    ThreadIdentity : 
    WindowsIdentity : IIS APPPOOL\NexusChurch
    Requested URL : http://www.nexuschurch.com.au/Sitefinity/Services/DynamicModules/ContentTypeService.svc/deactivate/
    Inner Exception
    ---------------
    Type : System.InvalidOperationException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Message : The type String cannot be constructed. You must configure the container to supply this value.
    Source : Telerik.Sitefinity.Utilities
    Help link : 
    Data : System.Collections.ListDictionaryInternal
    TargetSite : Void GuardTypeIsNonPrimitive(Telerik.Microsoft.Practices.ObjectBuilder2.IBuilderContext, Telerik.Microsoft.Practices.ObjectBuilder2.SelectedConstructor)
    HResult : -2146233079
    Stack Trace :    at Telerik.Microsoft.Practices.ObjectBuilder2.DynamicMethodConstructorStrategy.GuardTypeIsNonPrimitive(IBuilderContext context, SelectedConstructor selectedConstructor)
      at Telerik.Microsoft.Practices.ObjectBuilder2.DynamicMethodConstructorStrategy.PreBuildUp(IBuilderContext context)
      at Telerik.Microsoft.Practices.ObjectBuilder2.StrategyChain.ExecuteBuildUp(IBuilderContext context)
      at Telerik.Microsoft.Practices.ObjectBuilder2.DynamicMethodBuildPlanCreatorPolicy.CreatePlan(IBuilderContext context, NamedTypeBuildKey buildKey)
      at Telerik.Microsoft.Practices.ObjectBuilder2.BuildPlanStrategy.PreBuildUp(IBuilderContext context)
      at Telerik.Microsoft.Practices.ObjectBuilder2.StrategyChain.ExecuteBuildUp(IBuilderContext context)
      at Telerik.Microsoft.Practices.ObjectBuilder2.BuilderContext.NewBuildUp(NamedTypeBuildKey newBuildKey)
      at BuildUp_Telerik.Sitefinity.DynamicModules.Builder.ModuleBuilderManager(IBuilderContext )
      at Telerik.Microsoft.Practices.ObjectBuilder2.BuildPlanStrategy.PreBuildUp(IBuilderContext context)
      at Telerik.Microsoft.Practices.ObjectBuilder2.StrategyChain.ExecuteBuildUp(IBuilderContext context)
      at Telerik.Microsoft.Practices.Unity.UnityContainer.DoBuildUp(Type t, Object existing, String name, IEnumerable`1 resolverOverrides)


    Category: ErrorLog
    Priority: 0
    EventId: 90000
    Severity: Error
    Title:Enterprise Library Exception Handling
    Machine: AMAZONA-NT94267
    App Domain: /LM/W3SVC/9/ROOT-1-130258522154564135
    ProcessId: 3400
    Process Name: c:\windows\system32\inetsrv\w3wp.exe
    Thread Name: 
    Win32 ThreadId:6184
    Extended Properties: 
    ----------------------------------------


    Seth

      
6 posts, 0 answered