+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Adding tags to a search index

Adding tags to a search index

4 posts, 0 answered
  1. Joe
    Joe avatar
    21 posts
    Registered:
    01 Dec 2010
    11 Aug 2015
    Link to this post

    Did something happen in Sitefinity 8.0 from 7.3 involving indexing tags? I implemented this gist which was working great in 7.3, but now the tags aren't getting indexed at all anymore.

    https://gist.github.com/rhullah/bd71a5388db909b46e1e

    Is there a different way to add tags or a custom classification to a search index?

  2. Joe
    Joe avatar
    21 posts
    Registered:
    01 Dec 2010
    13 Aug 2015
    Link to this post
    After some more digging, I figured out the values of the custom fields that I have dictated in the search index aren't getting processed.  The only values going in are Title and Summary, which are the defaults.  Does anyone else have this issue of custom values not going into the search index even though I have added them to the 'Additional fields for indexing'? 
  3. Joe
    Joe avatar
    21 posts
    Registered:
    01 Dec 2010
    14 Aug 2015
    Link to this post
    I also took a fresh 8.0 project and created a search index looking at a dynamic content module, and added a custom short text field to the index.  Then I implemented a custom concatenation translator to determine the fields going into the search index, and the custom field is not going into the index.  This used to work in 7.x. 
  4. Joe
    Joe avatar
    21 posts
    Registered:
    01 Dec 2010
    17 Aug 2015
    Link to this post

    It looks this was a bug in 8.0.5710 and was fixed with and internal hotfix.

    http://www.sitefinity.com/developer-network/forums/internal-builds/sitefinity-8.0-internal-builds#HlFffME3622pWP8AAERlJg

     

4 posts, 0 answered