Try Now
More in this section

Forums / Developing with Sitefinity / Could not load file or assembly 'Telerik.Sitefinity.Analytics.Server.Infrastructure

Could not load file or assembly 'Telerik.Sitefinity.Analytics.Server.Infrastructure

2 posts, 1 answered
  1. Rohin
    Rohin avatar
    30 posts
    19 Jul 2014
    24 Jul 2014
    Link to this post
    Could not load file or assembly

    'Telerik.Sitefinity.Analytics.Server.Infrastructure, Version=4.3.1885.0,

    Culture=neutral, PublicKeyToken=null' or one of its dependencies. The

    located assembly's manifest definition does not match the assembly

    reference. (Exception from HRESULT: 0x80131040)
    This error occur when i'll upgrade to 7.1 version.
  2. Vassil Vassilev
     Vassil Vassilev avatar
    308 posts
    21 Jan 2015
    29 Jul 2014
    Link to this post
    Hello Rohin,

    Regarding the exception, apparently Sitefinity is looking for an older version of the Analytics assembly. This could happen e.g. if you have some external library built using an older Analytics version. This could be avoided if you rebuild the external library using the new Analytics dll used by your upgraded Sitefinity project.

    Another, faster approach to fix this is by adding a binding redirect in your web.config file:

        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
                <assemblyIdentity name="Telerik.Sitefinity.Analytics.Server.Infrastructure" publicKeyToken="YourToken" culture="neutral"/>
                <bindingRedirect oldVersion="" newVersion="your 7.0 dll version"/>

    I hope this helps. Please get back to me if the issue persists.

    Vassil Vassilev
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
2 posts, 1 answered