More in this section

Forums / Developing with Sitefinity / Creating custom page templates in sitefinity 4.1

Creating custom page templates in sitefinity 4.1

5 posts, 0 answered
  1. Shekar
    Shekar avatar
    35 posts
    Registered:
    11 Mar 2011
    08 Jun 2011
    Link to this post
    how can we create a custom page template in sitefinity 4.1 as in like sitefinity 3.6 [creating Master page in App_Master folder].
  2. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    18 Sep 2017
    09 Jun 2011
    Link to this post
    Hello Shekar,

    You can do it following the example master page in documentation. Note the path to App_Master is different in Sitefinity 4. After you create the template and place it in App_Master you need to go to the backend Design->Page Templates --> create new --> select From Template  there will be listed the default templates and at the bottom there is an option "upload your .master file" .

    I hope this helps. Write back if you need further assistance.

    Regards,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Shekar
    Shekar avatar
    35 posts
    Registered:
    11 Mar 2011
    10 Jun 2011
    Link to this post
    Thanks for your support - Stanislav Velikov. now i can assign my master page template to the pages.

    When trying to assign a theme to the template created it is showing an error message as "Could not find a part of the path 'C:\Inetpub\wwwroot\rgtest\App_Themes\MotoMicroWhite\Global\'."

    have registered the theme by following the link "http://www.sitefinity.com/documentation/designers-guide/creating-a-theme/registering-a-theme.aspx"

    Can you please help me out why this error message is displayed while trying to assign the newly registered theme to an template.

    Thanks in advance for your support.
  4. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    18 Sep 2017
    13 Jun 2011
    Link to this post
    Hi Shekar,

     I see that the path to the Theme is wrong. You should place it under your App_Data folder and the route you enter in the backend when you register the Theme should be relative including "~" symbol.
    ~/App_Data/Sitefinity/WebsiteTemplates/MotoMicroWhite/App_Themes/MotoMicro.
    Also make sure you use "/" instead of "\" and point the theme to its root folder not the Global folder.
    This will register the theme right and you will be able to use it.

    I hope this helps you. Please write back if you need more help. 

    Greetings,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Shekar
    Shekar avatar
    35 posts
    Registered:
    11 Mar 2011
    15 Jun 2011
    Link to this post
    Thanks  Stanislav Velikov, it works now.

    Thanks for your support.
5 posts, 0 answered