1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Custom PageNode fields not persisting in database

Custom PageNode fields not persisting in database

3 posts, 1 answered
  1. Jason
    Jason avatar
    0 posts
    Registered:
    28 Nov 2016
    01 Jun
    Link to this post

    I have a pretty simple yet frustrating problem trying to add new custom fields to our website. 

     

    I've inherited a website developed by a third party company, currently rolling with Sitefinity version 7.3.5610.0.  Our default page template came complete with a handful of custom fields to add a page link to the banner that persists across every page. I'm trying to add an additional custom text field to add an option to link offsite to a URL. 

     

    I can get the field to show up no problem, but I'm at a loss on how to force this field to presist in the page_node table. I've tried manually adding the field to the config files (all 6 of the frontend/backend create/edit/dialog), as well as adding it using the frontend interface in the advanced settings. Both ways fail to create a column for the new field in the database.

     

    I've been fighting this issue all day now, and I'm ready to reach out for some extra assistance.

  2. Victor Leontyev
    Victor Leontyev avatar
    65 posts
    Registered:
    01 Jul 2014
    04 Jun in reply to Jason
    Link to this post

    Hi Jason,

    Based on your description, i understood that you are trying to add fields through configs.

    Easiest way to add custom fields to page, is to use interface. Go to the backend -> Pages and then in right sidebar you will find "Custom fields"

    Answered
  3. Jason
    Jason avatar
    0 posts
    Registered:
    28 Nov 2016
    13 Jun in reply to Victor Leontyev
    Link to this post
    Wow, thank you, that's exactly what I needed. I appreciate you taking the time to help me out!
3 posts, 1 answered