1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Deploying Sitefinity in Network Balanced Environment

Deploying Sitefinity in Network Balanced Environment

9 posts, 0 answered
  1. jkregala
    jkregala avatar
    159 posts
    Registered:
    22 Sep 2009
    03 Aug 2011
    Link to this post
    This article is for 3.x, how do we apply for 4.1?

    Thanks.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    03 Aug 2011
    Link to this post
    Hi Jkregala,

    Please take a look at this article

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. jkregala
    jkregala avatar
    159 posts
    Registered:
    22 Sep 2009
    03 Aug 2011
    Link to this post
    Hi Ivan,

    as per our System Administrators:

    Our production web farm environment is not setup with Windows NLB. We are using citrix to load-balanced traffic to frontend servers. We have 1 front-end for content managers to update the content of the sites and 2 front-end servers for content delivery to subscribers. All front-end servers are using 1 content database. However, when content is populated, the front-end servers for subscribers does not render the updated content. what can we possibly do given our setup?
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    03 Aug 2011
    Link to this post
    Hi Jkregala,

    We have tested only with the Windows Network Load Balancing and this is what I can say that we support.  If there are some sync issues you could check whether the settings on all servers are correct

    1. In Sitefinity’s backend, click Administration » Settings » Advanced Settings » System » LoadBalancing » WebServerUrls » Create new.
    2. Enter the URLs of each of the frontend servers that are part of the load balancing and which will be used to access your website.

      EXAMPLE: The following are examples of the format of the URLs:
        • http://webserver1.telerik.com/
        • http://webserver2.telerik.com/
        • or enter directly the IP address:
          http://199.166.0.1/

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. jkregala
    jkregala avatar
    159 posts
    Registered:
    22 Sep 2009
    03 Aug 2011
    Link to this post
    This might be it:

    We have a separate website deployed, but it's in 3.7 version and everything is well. Once we update stuff in the staging server, the prod follows instantly. Same setup, with Citrix. In that website, we have this in the web.config:

    <telerik>
                    <dataAccess defaultConnection="DefaultConnection">
                            <cacheDependency mode="InDatabase"/>

    Do you have any equivalent for 4.1? We just need this part:

    <cacheDependency mode="InDatabase"/>
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    03 Aug 2011
    Link to this post
    Hello Jkregala,

    In Sitefinity 4.x there is no InDataBase config setting. When you create an item we create a cache dependency which notifies your servers about the change so a new dependency is created and an old one is invalidated.
    When you change an item we invalidate the cache.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. jkregala
    jkregala avatar
    159 posts
    Registered:
    22 Sep 2009
    03 Aug 2011
    Link to this post
    The only workaround is the previous thing you posted?
  8. jkregala
    jkregala avatar
    159 posts
    Registered:
    22 Sep 2009
    04 Aug 2011
    Link to this post
    Tried your suggestion, unfortunately it did not work.
  9. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    04 Aug 2011
    Link to this post
    Hello Jkregala,

    1. Make sure that you have restarted the applications
    2. Make sure that you have the same cofiguration files on both the iis instances.

    You can also take a look at this thread

    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/load-balancing-configuration-question.aspx


    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
9 posts, 0 answered