Try Now
More in this section

Forums / Developing with Sitefinity / Failed Workflow Operation

Failed Workflow Operation

2 posts, 0 answered
  1. Ajay
    Ajay avatar
    46 posts
    14 Nov 2013
    31 Jan 2015
    Link to this post

    Hi All, I'm using Sitefinity 7.0 

    I'n Local machine working Perfect :) but i moved Code to Server, Now i'm Getting few Errors

    1. While Creating Page I'm Getting "Failed Workflow operation" Error (attached1)

    2. if i open Templates (design->pageTemplates) , Pages ,and Entering Related Records of Module I'm Getting Title Error (Attached2)

    3. Few Times while Creating Page time, I'm Unable to Find out Publish Button Getting "Unexpected Tocken" error .


    Please Help me how to solve these Issues 

    Thanks in Advance

    Ajay Reddy

  2. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    24 Oct 2016
    04 Feb 2015
    Link to this post
    Hi Ajay,

    The issue reproduces only on your production environment it seems that it is related to your environment settings. 

    Since by default the workflow functions only under http the "Failed Workflow operation" might be caused if you have any rewrite rules in your web.config file for redirecting all http requests to https. If so, can you please take a look at the following KB in order to exclude the workflow from the switch: Forcing all site's traffic under SSL prevents publishing content and pages

    In addition I would also advice to check the following KB article which might also help you to fix the issue which you are experiencing when publishing pages.
    Pages cannot be published after installation

    Furthermore, can you please also review the following articles and make sure that you have configured your environment properly:

    Configuring the IIS to host Sitefinity projects

    Running a project on IIS 7.0 and above
    You can download from the following article and execute the PowerShell script (depending on the IIS version) in order to make sure that all the needed Windows features are turned on your production server and IIS is configured properly to host Sitefinity projects.

    Regarding the "Connection reset by peer" exception it seems to be a network related issue and it is a bit difficult to say what might be causing this. I did a research and found the following articles which are describing what is causing this kind of issues:




    Sabrie Nedzhip
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
2 posts, 0 answered