1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Getting error when I added .aspx to the url

Getting error when I added .aspx to the url

2 posts, 0 answered
  1. Annie
    Annie avatar
    46 posts
    Registered:
    11 Aug 2012
    27 Mar 2012
    Link to this post
    Hi,

    I am getting the following error when I added the .aspx extension to a page url. The url looks like this now:

    http://test/test.aspx/.aspx/.aspx/.aspx/.aspx/.aspx/.aspx/.aspx/.aspx/.aspx/.aspx
     

    Server Error in '/' Application.

    The length of the URL for this request exceeds the configured maxUrlLength value.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Web.HttpException: The length of the URL for this request exceeds the configured maxUrlLength value.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [HttpException (0x80004005): The length of the URL for this request exceeds the configured maxUrlLength value.]
       System.Web.HttpRequest.ValidateInputIfRequiredByConfig() +11494238
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +375
    

    Thanks,
    Annie
  2. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    28 Mar 2012
    Link to this post
    Hello Annie,

    This is general error, which is related to the fact that the URL is longer than expected. The following article may be useful to you: http://msdn.microsoft.com/en-us/library/system.web.configuration.httpruntimesection.maxurllength.aspx - if you want to increase the maxurllength setting  you need to add / edit the following section in your web.config file:

    <system.web>
      <httpRuntime maxUrlLength="4096" /> (for example)

    On a side note: the url seems to contain some forbidden symbols ( such as the dot ) which may lead to false URLs as well.


    Kind regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered