1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Image field of custom module

Image field of custom module

3 posts, 1 answered
  1. Majid
    Majid avatar
    17 posts
    Registered:
    02 Jun 2011
    12 Nov 2011
    Link to this post
    Hi,
    I have developed a module using Product SDK module.I have a field named Thumbnail which can save an image. it's exactly like product image! but the problem is, I cannot show it on List and Detail view. when I use <sf:imageField... I have "Error parsing.." message. 
    this is my list view control:
    FYI: I have no problem in Backend to save and image 

    <%@ Control Language="C#" %>
    <%@ Register TagPrefix="telerik" Namespace="Telerik.Web.UI" Assembly="Telerik.Web.UI" %>
    <%@ Register TagPrefix="sf" Namespace="Telerik.Sitefinity.Web.UI" Assembly="Telerik.Sitefinity" %>
    <%@ Register TagPrefix="sf" Namespace="Telerik.Sitefinity.Web.UI.ContentUI" Assembly="Telerik.Sitefinity" %>
    <%@ Register TagPrefix="sf" Namespace="Telerik.Sitefinity.Web.UI.PublicControls.BrowseAndEdit" Assembly="Telerik.Sitefinity" %>
    <%@ Register TagPrefix="sf" Namespace="Telerik.Sitefinity.Web.UI.Fields" Assembly="Telerik.Sitefinity" %>


    <telerik:RadListView ID="ProjectList" ItemPlaceholderID="ItemsContainer" runat="server" EnableEmbeddedSkins="false" EnableEmbeddedBaseStylesheet="false">
        <LayoutTemplate>
        <div class="projects-wrap project-list-wrap project-list-wrap-expanded">
        <div class="paging-container">
        <div class="paging-container"><span class="paging-btn prev disabled">Prev</span><span class="paging-btn next">next</span></div>
        <div class="project-list">
        <div class="project-list-mask">
            <ul>
                <asp:PlaceHolder ID="ItemsContainer" runat="server" />
            </ul>
            </div></div></div></div>
        </LayoutTemplate>
        <ItemTemplate>
            <li>
                <h3>
                    <sf:DetailsViewHyperLink ID="DetailsViewHyperLink1" TextDataField="Title" ToolTipDataField="Description" runat="server" />
                </h3>
            <div class="thumb"><sf:ImageField ID="thumbnailImageField" runat="server"  DataFieldType="Telerik.Sitefinity.Model.ContentLinks.ContentLink"  
       DisplayMode="Read" DataFieldName="Thumbnail" /></div>
                <div class="desc">
    <a href="#" class="active">Latest Project News</a>
    <sf:DetailsViewHyperLink ID="FullStory" Text="View Project" runat="server" CssClass="sfnewsFullStory" />
    <a href="#">Register Interest</a>
    </div>


                
                <sf:ContentBrowseAndEditToolbar ID="BrowseAndEditToolbar" runat="server" Mode="Edit,Delete,Unpublish"></sf:ContentBrowseAndEditToolbar>
            </li>
        </ItemTemplate>
    </telerik:RadListView>
    <sf:Pager id="pager" runat="server"></sf:Pager>

    I sent my entire module in ticket  482445 in hope of having fast and complete answer :)

    Cheers,
    Majid
  2. Majid
    Majid avatar
    17 posts
    Registered:
    02 Jun 2011
    15 Nov 2011
    Link to this post
    Hi All,
    Is there anyone who has any solutions?! I really don't know what is the problem.
    Any help would be appreciated.  

    Thanks
  3. Svetoslav Petsov
    Svetoslav Petsov avatar
    456 posts
    Registered:
    24 Sep 2012
    16 Nov 2011
    Link to this post
    Hello Majid,

     Your support ticket has been answered, the issue is not reproduced here with your module. Please check the support ticket and see if you could provide some more information.

    Greetings,
    Svetoslav Petsov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
3 posts, 1 answered