1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Losing bin files when adding class library

Losing bin files when adding class library

9 posts, 1 answered
  1. John S.
    John S. avatar
    126 posts
    Registered:
    09 Aug 2004
    20 Sep 2011
    Link to this post
    Hello,

    If I open a project in Visual Studio from the project manager and add a Class Library as a project to the solution most of the dlls in the SitefinityWebApp disappear causing a large number of errors. If I paste the dlls back in the bin directory, the same thing happens. If I paste the dlls back in the bin directory and remove the Class Library all works well.

    Any suggestions?

    Thanks,
    John
  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    21 Sep 2011
    Link to this post
    I know that doing a "Rebuild" (not Build) in Visual studio will cause most of the dlls to disappear...is that whats happening?
    Answered
  3. John S.
    John S. avatar
    126 posts
    Registered:
    09 Aug 2004
    21 Sep 2011
    Link to this post
    Hi Steve,

    Yes, just checked it out and that is what's happening. I thought it had to do with the Class Library.

    So is the solution is "don't use rebuild" or is there something that needs to be changed?

    Thanks,
    John
  4. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    21 Sep 2011
    Link to this post
    Nope literally that simple...try and train yourself out of it :)

    I believe there's a PITS issue to try and fix that...but pits is a nightmare to navigate so please excuse my unwillingness to go a-browsing :)
  5. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    21 Sep 2011
    Link to this post
    If this answers the post, could I bug you to Mark as Answered perhaps? :)
  6. Mayvelous
    Mayvelous avatar
    43 posts
    Registered:
    26 May 2011
    21 Sep 2011
    Link to this post
    For me, I place all dlls in separate folder and rereferencing them from the project so no need to worry about breaking the site upon build/rebuild action. If you like, you can check my notes here.
  7. John S.
    John S. avatar
    126 posts
    Registered:
    09 Aug 2004
    21 Sep 2011
    Link to this post
    Thank you Steve and Mayvelous for your responses.
  8. John
    John avatar
    97 posts
    Registered:
    11 Jan 2011
    22 Sep 2011
    Link to this post
    HI

    Make all relevant dlls in \bin read only. That's what I do and even if I rebuild thery stay.

    Regards

    Yahya
  9. Jaymie
    Jaymie avatar
    27 posts
    Registered:
    30 Jan 2009
    09 Aug 2012
    Link to this post
    I just had the same thing happen in v5

    All your DLL's are in the _EmptyProject folder in the root of  C:\Program files\Telerik\Sitefinity 5.0 folder for version 5.0
9 posts, 1 answered