1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Pages not showing in navigation even when published and show in navigation set to true

Pages not showing in navigation even when published and show in navigation set to true

5 posts, 0 answered
  1. Annie
    Annie avatar
    46 posts
    Registered:
    11 Aug 2012
    24 Mar 2012
    Link to this post
    Hi 

    Some pages are not showing in navigation even when published and show in navigation set to true. What is causing this issue?

    Thanks,
    Annie
  2. Grace Hallwachs
    Grace Hallwachs avatar
    144 posts
    Registered:
    03 Nov 2014
    27 Mar 2012
    Link to this post
    Hello Annie,

    Can you please send more information about the pages that are not showing in navigation? If possible, can you send screen shots of the affected pages?

    Greetings,
    Grace Hallwachs
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    27 Mar 2012
    Link to this post
    Dear Annie
    In case you are using pages that redirect to another page in the site then the following is true.
    The page redirecting will NOT be shown if the page which it redirects to is not set to be shown in the navigation.
    So you can publish an redirect page, set it to be shown in navigation BUT if the page redirecting to is not shown also the page redirecting will not show.
    Work around: link to it as if it was an external page http://......
    If this is the case, vote for it:
    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/suggestions/redirect-pages-show-in-navigation-only-when.aspx

    If its anything else. You need to provide more informationas Grace mentioned.

    Markus
  4. Annie
    Annie avatar
    46 posts
    Registered:
    11 Aug 2012
    27 Mar 2012
    Link to this post
    Hi Grace,

    The problem was occurring with a page that was migrated from sitefinity 3.7, I created some child pages for this page, and they were not external pages and navigation was set to true, but for some reason no matter what I tried the child pages would not show up in navigation. So I deleted the migrated page, recreated this page again and added child pages to this that worked.

    Thanks,
    Annie
  5. Annie
    Annie avatar
    46 posts
    Registered:
    11 Aug 2012
    27 Mar 2012
    Link to this post
    Hi Markus,

    The problem was occurring with child pages of a page that was migrated from sitefinity 3.7, the child pages were not redirecting to an external page and the navigation was set to true

    Thanks,
    Annie
5 posts, 0 answered