+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Personify Connector Property Error!

Personify Connector Property Error!

6 posts, 0 answered
  1. Ahsan
    Ahsan avatar
    9 posts
    Registered:
    23 Dec 2014
    13 Mar 2015
    Link to this post

    Hi There,

    I was setting properties for the  personify “Product Listing” control to launch a “Product Detail” page. Upon saving those 3 property values, I got this error – and now it can’t see properties of any
    control on any page but server error page.

    Attaching 2 files here to help diagnose the issue!

    1.  Personify Control – Set Property – Error Flow.jpg
         (This is how error ‘been generated, and yes reproducible.)

    2.  Personify Property Set - Server Error Detail.jpg
          (Web browser pop-up window, display this error. )

    Thanks,
    -Ahsan


  2. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    07 Dec 2016
    18 Mar 2015
    Link to this post
    Hi Ahsan,

    The error is very general. Most probably there is some property passed which is null in the control. You can try to debug it and add additional check for that value if needed.

    You can provide us with your code in order to inspect it or if you prefer to open a support ticket where to provide the entire control.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Ahsan
    Ahsan avatar
    16 posts
    Registered:
    12 Mar 2015
    18 Mar 2015 in reply to Svetoslav Manchev
    Link to this post

    Thank you Svetoslav, for addressing; I believe you are right, that some value has been set to null. 

    And we are not sure where (DB table, Config file)  those property setting/values goes.
    tried Fiddler to trace back, but not helpful either except generic error - If nothing worked out I am afraid we might have to reconfigure the website solution. 

    I have little hope that if I am able to identify the DB table, where control values goes ... i might able to make this out without re-installing the whole gigantic solution.

     

    Thanks,

    -Ahsan

     

  4. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    07 Dec 2016
    19 Mar 2015
    Link to this post
    Hi Ahsan,

    The error shows object reference on needdatasource method., so I would recommend to debug your control and check the datasource for product detail url selector.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  5. Ahsan
    Ahsan avatar
    16 posts
    Registered:
    12 Mar 2015
    19 Mar 2015 in reply to Svetoslav Manchev
    Link to this post
    Thanks Svetoslav!
  6. Ahsan
    Ahsan avatar
    16 posts
    Registered:
    12 Mar 2015
    19 Mar 2015
    Link to this post

    This Problem was caused by the incompatibility of Telerik.Web.UI.dll. 

    So the solution is, as following:

    1.  place a Telerik.Web.UI.dll in the bin folder with a newer version (2014.2.618.40 in our case) to support Sitefinify 7.1.5200.0 personify controls. You can get this DLL by compiling your "eBusiness\WebControls".

    2. Create a new folder under bin (in our case we go like: bin\PersonifyDLLs\) and place older version of Telerik.Web.UI.dll (in our case we have 2012.3.1322.40).

    3. add the following code in web.config anywhere 

    <configuration> 
      <configSections>
       <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <probing privatePath="PersonifyDLLs" />
          <dependentAssembly>
            <assemblyIdentity name="Telerik.Web.UI" publicKeyToken="121fae78165ba3d4" />
            <codeBase version="2012.3.1322.40" href="PersonifyDLLs/Telerik.Web.UI.dll" />
            <codeBase version="2014.2.618.40" href="Telerik.Web.UI.dll" />
          </dependentAssembly>
        </assemblyBinding>
      </runtime> 
      <configSections> 
    <configuration> 

    So basically we have to create assembly binding.

    please feel free to contact if you need more help on this matter. 

    Thnaks,
    -Ahsan

6 posts, 0 answered