+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / SF9.0 works fine in Cassini but wants to use MySQL for IIS

SF9.0 works fine in Cassini but wants to use MySQL for IIS

6 posts, 0 answered
  1. readonlychild
    readonlychild avatar
    67 posts
    Registered:
    26 May 2011
    18 Apr
    Link to this post

    I have a site that has been recently upgraded to v9.0 (from v7.2)

    Within Visual Studio, if I use the option (right-click) project, "View in Browser", the site comes up fine with a url like "localhost:51234". Backend works and I can browse fine.

    I guess I do not know how to do multiple domain bindings in the Visual Studio webserver, So I setup the same site to be an IIS website, and this has worked fine before upgrading to v9.0.

    But when I try to get to the website from IIS, I am presented with error: 

     

    Authentication to host '' for user '' using method 'mysql_native_password' failed with message: Access denied for user ''@'user.domain.stuff' (using password: NO) (C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config\machine.config line 285)

     

    Same DataConfig.config, same everything, but Sitefinity wants to work with MySQL for whatever reason...

    here are the relevant attributes from connectionStrings

     providerName="System.Data.SqlClient" dbType="MsSql" name="Sitefinity"

     

     

  2. Pavel Benov
    Pavel Benov avatar
    21 posts
    Registered:
    29 Nov 2016
    28 Apr
    Link to this post
    Hi Ernesto,

    Were you able to solve this problem? Have you checked the ports in case you have used some that is already been taken by another application? Do you have any errors in the logs (App_Data->Siteifnity->Logs)? You may need to open a support ticket for this issue.

    Regards,
    Pavel Benov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. André
    André avatar
    2 posts
    Registered:
    23 Sep 2014
    17 May
    Link to this post

    Hello

    i have the same problem by a new install.

     

    greeting andreas

  4. Pavel Benov
    Pavel Benov avatar
    21 posts
    Registered:
    29 Nov 2016
    20 May
    Link to this post
    Hi guys,

    Can you attach your log files (located in App_Data->Sitefinity->Logs folder) to this thread so I can take a look?

    Regards,
    Pavel Benov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  5. readonlychild
    readonlychild avatar
    67 posts
    Registered:
    26 May 2011
    02 Jun
    Link to this post

    @Pavel, I cleaned the Logs folder, and started the webapp (in the browser) the gears spin, break, and show me the error. Nothing is logged, the folder stays empty.

    @Andre, the error points me to ...\machine.config, there are entries referencing MySql sprinkled around... I removed them all and I got further...

  6. Pavel Benov
    Pavel Benov avatar
    21 posts
    Registered:
    29 Nov 2016
    02 Jun
    Link to this post
    Hi guys,

    It seems that IIS would take the MySql provider with priority (defined in the machine.config). You can try commenting out the reference from there which should help out.

    You can also check the following Stackoverflow link:

    http://stackoverflow.com/questions/26189699/asp-net-mvc4-configuration-error-after-installing-mysql-connector-net

    Regards,
    Pavel Benov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
6 posts, 0 answered