+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Show Module in Content > Types of Content

Show Module in Content > Types of Content

7 posts, 0 answered
  1. Khoa
    Khoa avatar
    10 posts
    Registered:
    03 Dec 2013
    09 Jan 2014
    Link to this post
    Hi team,

    I have a problem. I create new module called Doctor based on your Jobs Module in SDK 6.3. I want Doctor Module show on Content > Types of Content in SF backend as Jobs. How can I do that?

    Please view attach file for more detail.

    Thanks,
  2. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    09 Jan 2014 in reply to Khoa
    Link to this post
    Hi Khoa,

    Did you checked if the module is loaded and active in the installed modules list (Administration -> Modules & Services). Any missing Resources?

    Any particular reason you are not using the Dynamic Module Builder for this? Just asking, since I converted most of my custom modules to Dynamic Modules and it is a lot easier to maintain.

    Kind regards,
    Daniel
  3. Khoa
    Khoa avatar
    10 posts
    Registered:
    03 Dec 2013
    09 Jan 2014 in reply to Daniel Plomp
    Link to this post
    Hi Daniel,

    Thanks for your reply. I am sure the module is active in Administration -> Modules & Services and not missing any resource.

    I create new module from scratch following the Job module in SDK. Could you let me know basically to show Custom Module in Content > Types of Content in SF backend?

    As I know there are some ways to create custom module in SF:
    - Creating new module by Sitefinity Module Builder
    - Creating new module by Sitefinity Thunder
    - Creating new module from scratch

    Is there any else way? And please let me know which is the best way to create custom module?

    Thanks so much,
    Khoa
  4. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    09 Jan 2014 in reply to Khoa
    Link to this post
    Hi Khoa,

    If you followed the the example in the SDK, it should show up there. My experience is that most of the time you don't have the right resources. You also restarted your website? Can you check the error.log?

    Depending on your needs I would definitely go with the Sitefinity Module Builder.

    Kind regards,
    Daniel.
  5. Khoa
    Khoa avatar
    10 posts
    Registered:
    03 Dec 2013
    09 Jan 2014
    Link to this post
    Hi Daniel,

    This is error from Error.log:

    ----------------------------------------
    Timestamp: 1/9/2014 8:47:24 AM

    Message: HandlingInstanceID: 5cdb290a-2ac4-4cbc-a9c2-7f0d1e1a4faf
    An exception of type 'System.Web.HttpException' occurred and was caught.
    ------------------------------------------------------------------------
    01/09/2014 15:47:24
    Type : System.Web.HttpException, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
    Message : File does not exist.
    Source : System.Web
    Help link : 
    WebEventCode : 0
    ErrorCode : -2147467259
    Data : System.Collections.ListDictionaryInternal
    TargetSite : Boolean ProcessRequestForNonMapPathBasedVirtualFile(System.Web.HttpRequest, System.Web.HttpResponse, System.String)
    HResult : -2147467259
    Stack Trace :    at System.Web.StaticFileHandler.ProcessRequestForNonMapPathBasedVirtualFile(HttpRequest request, HttpResponse response, String overrideVirtualPath)
       at System.Web.StaticFileHandler.ProcessRequestInternal(HttpContext context, String overrideVirtualPath)
       at System.Web.DefaultHttpHandler.BeginProcessRequest(HttpContext context, AsyncCallback callback, Object state)
       at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    Additional Info:

    MachineName : KHOA-PC
    TimeStamp : 1/9/2014 8:47:24 AM
    FullName : Telerik.Sitefinity.Utilities, Version=6.3.5000.0, Culture=neutral, PublicKeyToken=b28c218413bdf563
    AppDomainName : dcc57219-1-130337307645519815
    ThreadIdentity : 
    WindowsIdentity : Khoa-PC\Khoa
    Requested URL : http://localhost:60876/favicon.ico


    Category: ErrorLog

    Priority: 0

    EventId: 90000

    Severity: Error

    Title:Enterprise Library Exception Handling

    Machine: KHOA-PC

    App Domain: dcc57219-1-130337307645519815

    ProcessId: 9252

    Process Name: C:\Program Files (x86)\Common Files\Microsoft Shared\DevServer\11.0\WebDev.WebServer40.exe

    Thread Name: 

    Win32 ThreadId:6300

    Extended Properties: 
    ----------------------------------------

    Could you let me know the error.

    Thanks,
    Khoa
  6. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    09 Jan 2014 in reply to Khoa
    Link to this post
    Hi Khoa,

    Some things to check maybe:

    • Do you have the right VirtualPath providers in the VirtualPathProviderConfig.config file?
    • Did you marked the .ascx and .js files inside your custom project to be 'Embedded Resources'?

    Kind regards,
    Daniel

  7. Teodor Georgiev
    Teodor Georgiev avatar
    2 posts
    Registered:
    29 Apr 2010
    09 Jan 2014 in reply to Daniel Plomp
    Link to this post
    Hi ,

    first of all this exception is for favicon.ico which means that the icon is missing or the web server is not processing .ico files as mime type. 

    second 

    i have experience the same problem when my module name set in the module is different from the one used to register the module. When you register pages through the API that are for content module there is a code that defines for which module they are used and after that when the page is requested there is a code that checks if the module is activated and verify that by module name. 

7 posts, 0 answered