1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Sitefinity custom Module problem (from SF Nuts and bolts Content based Email example)

Sitefinity custom Module problem (from SF Nuts and bolts Content based Email example)

2 posts, 0 answered
  1. Bloommedia
    Bloommedia avatar
    10 posts
    Registered:
    18 May 2009
    04 Jul 2011
    Link to this post
    Hi,

    I have recently purchased the Sitefinity nuts and Bolts book and worked through the installation of the Content based Email module, I have encountered a problem when registering this module in Sitefinity.  The Module appears in the Advanced Settings as expected however I am unable to get the module to appear in the Contents List drop down menu despite following the steps and even using the source code directly.

    I have specified OnApplicationStart as startup type, I have restarted Sitefinity by closing down the browser, closing the ASP.NET internal development server and updating the web.config, but the module refuses to appear in the content list.  The minimal module example does appear however to Im wondering of this is an OpenAccess issue?

    My SystemConfig looks like this:
    <?xml version="1.0" encoding="utf-8"?>
    <systemConfig build="1501" previousBuild="1395">
        <servicesModules>
            <add version="4.1.1501.0" name="Search" />
        </servicesModules>
        <applicationModules>
            <add version="4.1.1501.0" name="News" />
            <add version="4.1.1501.0" name="Blogs" />
            <add version="4.1.1501.0" name="Events" />
            <add version="4.1.1501.0" name="Libraries" />
            <add version="4.1.1501.0" name="Forms" />
            <add version="4.1.1501.0" name="Lists" />
            <add version="4.1.1395.0" name="Analytics" />
            <add version="4.1.1395.0" name="Scheduling" />
            <add version="4.1.1395.0" name="Publishing" />
            <add version="4.1.1395.0" name="Newsletters" />
            <add version="4.1.1395.0" name="GenericContent" />
            <add version="4.1.1395.0" name="ControlTemplates" />
            <add title="Email Module" description="Email" resourceClassId="" type="Email.EmailModule" startupType="OnApplicationStart" name="EmailModule" />
        </applicationModules>
    </systemConfig>

    Does anyone know of any issues that could lead me in the right direction with this as I have deadlines looming!

    Thanks.
     
  2. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    04 Jul 2011
    Link to this post
    Hi,

    I have answered you in the support ticket you have opened regarding the same issue.

    Greetings,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered