+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Thunder Problem in VS 2015

Thunder Problem in VS 2015

11 posts, 0 answered
  1. Brian
    Brian avatar
    26 posts
    Registered:
    12 Jun 2015
    29 Apr
    Link to this post

    I posted this same info in the VS gallery

    I am not sure what started it, but this last week, I get an alert that Thunder failed to load.  I have tried reinstalling the module, and even reinstalling VS with no success.  The pertinent lines in the activity file log are:

    <entry>
      <record>735</record>
      <time>2016/04/29 21:15:40.469</time>
      <type>Warning</type>
      <source>VisualStudio</source>
      <description>Performance warning: String load failed. Pkg:{6862504F-7151-4472-A6CE-1F7345058EAC} (Telerik.Sitefinity.Thunder.ThunderPackage, Telerik.Sitefinity.Thunder, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b28c218413bdf563) LANG:0409 ID:200 </description>
    </entry>
    <entry>
      <record>736</record>
      <time>2016/04/29 21:15:40.471</time>
      <type>Warning</type>
      <source>VisualStudio</source>
      <description>Performance warning: String load failed. Pkg:{6862504F-7151-4472-A6CE-1F7345058EAC} (Telerik.Sitefinity.Thunder.ThunderPackage, Telerik.Sitefinity.Thunder, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b28c218413bdf563) LANG:0409 ID:200 </description>
    </entry>
    <entry>
      <record>737</record>
      <time>2016/04/29 21:15:41.646</time>
      <type>Error</type>
      <source>VisualStudio</source>
      <description>SetSite failed for package [Telerik.Sitefinity.Thunder.ThunderPackage, Telerik.Sitefinity.Thunder, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b28c218413bdf563][There is an error in XML document (0, 0).]:{   at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)    at System.Xml.Serialization.XmlSerializer.Deserialize(TextReader textReader)    at Telerik.Sitefinity.Thunder.Core.Configuration.FileConfigurationProvider.ReadConfiguration()    at Telerik.Sitefinity.Thunder.Core.Configuration.FileConfigurationProvider..ctor()    at Telerik.Sitefinity.Thunder.Core.Configuration.FileConfigurationProvider.GetProvider()    at Telerik.Sitefinity.Thunder.ThunderPackage.Initialize()    at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp)}</description>
      <guid>{6862504F-7151-4472-A6CE-1F7345058EAC}</guid>
      <hr>80131509</hr>
      <errorinfo>There is an error in XML document (0, 0).</errorinfo>
    </entry>
    <entry>
      <record>738</record>
      <time>2016/04/29 21:15:41.659</time>
      <type>Error</type>
      <source>VisualStudio</source>
      <description>End package load [Telerik.Sitefinity.Thunder.ThunderPackage, Telerik.Sitefinity.Thunder, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b28c218413bdf563]</description>
      <guid>{6862504F-7151-4472-A6CE-1F7345058EAC}</guid>
      <hr>80131509</hr>
      <errorinfo>There is an error in XML document (0, 0).</errorinfo>
    </entry>

    I am getting ready to support a very large client that already has Sitefinity, and I need to be ready ASAP.  Any help would be appreciated

     

     

     

  2. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    29 Sep 2016
    04 May
    Link to this post
    Hi,

    Please, take a look at the following KB articles:
    http://www.sitefinity.com/developer-network/knowledge-base/details/sitefinity-and-thunder-support-for-visual-studio-2015

    http://www.sitefinity.com/developer-network/knowledge-base/details/thunder-fails-to-install-with-visual-studio-2015

    http://www.sitefinity.com/developer-network/knowledge-base/details/thunder-authentication-doesn-t-use-then-the-loging-page-is-ssl-protected



    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Brian
    Brian avatar
    26 posts
    Registered:
    12 Jun 2015
    04 May in reply to Nikola Zagorchev
    Link to this post

    Hi Nikola,

    Thank you for the reply.  However, none of those links relate to the issue I am having.  The issue comes after the install, but before VS even finishes starting up, hence the activity file snippet from above.

    Based on the logging above, it looks as though it cannot find the configuration file, or that it is somehow malformed.  If I knew where it is supposed to be located, I could check myself.

    I am attaching an image to show the popup message. However, it does not give any real info, which is why I started with the logging snippet.

  4. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    29 Sep 2016
    04 May
    Link to this post
    Hi Brian,

    Please, check the following forum thread
    http://www.sitefinity.com/developer-network/forums/thunder/install-thunder-module-fail-on-vs-2013-win-8-64bit

    It provides a solution to the problem you report with the package.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  5. Brian
    Brian avatar
    26 posts
    Registered:
    12 Jun 2015
    04 May in reply to Nikola Zagorchev
    Link to this post

    Thank you.

    I uninstalled the module.  Then I did a search of everything Thunder related  under ...\AppData\Local\Microsoft\VisualStudio and deleted it all.  I then installed the extension again, with the same results.  I am attaching an image for the search results from the same VS directory after the install.  You will note that there is only one randomly named directory.

    I am including the ActivityLog.xml snippet below from the latest attempt, including everything from the Begin Package Load statement through the End Package Load statement.  It still looks to be complaining about the config file for the extension, and I do not see one in the listing attached (not that I really know what I am looking for). 

    Would it be possible to find out where that config file is supposed to be located and/or what its name is?  If it is missing or corrupted, I could copy it over from another machine maybe.

     

    <entry>
      <record>740</record>
      <time>2016/05/04 14:47:44.805</time>
      <type>Information</type>
      <source>VisualStudio</source>
      <description>Begin package load [Telerik.Sitefinity.Thunder.ThunderPackage, Telerik.Sitefinity.Thunder, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b28c218413bdf563]</description>
      <guid>{6862504F-7151-4472-A6CE-1F7345058EAC}</guid>
    </entry>
    <entry>
      <record>741</record>
      <time>2016/05/04 14:47:44.831</time>
      <type>Information</type>
      <source>VisualStudio</source>
      <description>Entering function VBDispatch::GetTypeLib</description>
    </entry>
    <entry>
      <record>742</record>
      <time>2016/05/04 14:47:44.831</time>
      <type>Information</type>
      <source>VisualStudio</source>
      <description>Leaving function VBDispatch::GetTypeLib</description>
      <guid>{80CC9F66-E7D8-4DDD-85B6-D9E6CD0E93E2}</guid>
    </entry>
    <entry>
      <record>743</record>
      <time>2016/05/04 14:47:44.835</time>
      <type>Warning</type>
      <source>VisualStudio</source>
      <description>Performance warning: String load failed. Pkg:{6862504F-7151-4472-A6CE-1F7345058EAC} (Telerik.Sitefinity.Thunder.ThunderPackage, Telerik.Sitefinity.Thunder, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b28c218413bdf563) LANG:0409 ID:200 </description>
    </entry>
    <entry>
      <record>744</record>
      <time>2016/05/04 14:47:44.836</time>
      <type>Warning</type>
      <source>VisualStudio</source>
      <description>Performance warning: String load failed. Pkg:{6862504F-7151-4472-A6CE-1F7345058EAC} (Telerik.Sitefinity.Thunder.ThunderPackage, Telerik.Sitefinity.Thunder, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b28c218413bdf563) LANG:0409 ID:200< /description>
    </entry>
    <entry>
      <record>745</record>
      <time>2016/05/04 14:47:44.906</time>
      <type>Error</type>
      <source>VisualStudio</source>
      <description>SetSite failed for package [Telerik.Sitefinity.Thunder.ThunderPackage, Telerik.Sitefinity.Thunder, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b28c218413bdf563][There is an error in XML document (0, 0).]:{   at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)    at System.Xml.Serialization.XmlSerializer.Deserialize(TextReader textReader)    at Telerik.Sitefinity.Thunder.Core.Configuration.FileConfigurationProvider.ReadConfiguration()    at Telerik.Sitefinity.Thunder.Core.Configuration.FileConfigurationProvider..ctor()    at Telerik.Sitefinity.Thunder.Core.Configuration.FileConfigurationProvider.GetProvider()    at Telerik.Sitefinity.Thunder.ThunderPackage.Initialize()    at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp)}</description>
      <guid>{6862504F-7151-4472-A6CE-1F7345058EAC}</guid>
      <hr>80131509</hr>
      <errorinfo>There is an error in XML document (0, 0).</errorinfo>
    </entry>
    <entry>
      <record>746</record>
      <time>2016/05/04 14:47:44.914</time>
      <type>Error</type>
      <source>VisualStudio</source>
      <description>End package load [Telerik.Sitefinity.Thunder.ThunderPackage, Telerik.Sitefinity.Thunder, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b28c218413bdf563]</description>
      <guid>{6862504F-7151-4472-A6CE-1F7345058EAC}</guid>
      <hr>80131509</hr>
      <errorinfo>There is an error in XML document (0, 0).</errorinfo>
    </entry>

     

    Thank you!

    Brian


  6. Brian
    Brian avatar
    26 posts
    Registered:
    12 Jun 2015
    05 May
    Link to this post
    Hi.  I am not sure how much difference this might make, but I have a VM where this does work on.  As far as I can tell, the biggest difference is that on the VM, VS is still running Update 1, whereas the broken install is running Update 2.  I am attaching screenshots in case you can see anything else.
  7. Brian
    Brian avatar
    26 posts
    Registered:
    12 Jun 2015
    10 May
    Link to this post
    Any more thoughts on this?
  8. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    29 Sep 2016
    11 May
    Link to this post
    Hello,

    Could you please specify your Sitefinity version? What is the version of Thunder - the latest one is 1.6.0.0?
    What is the OS you are using?

    You can also check these threads:
    https://connect.microsoft.com/VisualStudio/feedback/details/1123745/setsite-failed-for-package-microsoft-visualstudio-editor-implementation-editorpackage

    http://stackoverflow.com/questions/31741405/error-setsite-failed-for-package-apachecordovatoolspackage

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  9. Brian
    Brian avatar
    26 posts
    Registered:
    12 Jun 2015
    13 May in reply to Nikola Zagorchev
    Link to this post

    I am working two versions of Sitefinity for this client.  One is 9.0.6000.0 ,while the other is 7.3.5610.0.  Thunder is 1.6.0.0.  Neither of the links apply.  Thunder installs without complaint (first link), it just will not start due to the error I mentioned previously, and so never tries to connect (second link).  

    As to the first link, I not only uninstalled Thunder.  I uninstalled Visual Studio and then reinstalled them both, using the method for Thunder mentioned in the first link.

  10. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    29 Sep 2016
    18 May
    Link to this post
    Hello Brian,

    Would it be possible to try with another version of Visual Studio - 2012 or 2013? Please, check this thread as well:
    http://stackoverflow.com/questions/31547947/packages-not-loading-after-installing-visual-studio-2015-rtm

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  11. Brian
    Brian avatar
    26 posts
    Registered:
    12 Jun 2015
    18 May in reply to Nikola Zagorchev
    Link to this post

    VS 2012 has the same error.

    I tried the various solutions presented in the link with no change in behavior.

    I have a VM I can use for the moment, but I am that was meant as a test bed to prevent issues with my main machine.  I am now starting on work for that client with two projects immediately, and three more possible in the near future.

    One of them is to upgrade the version 7 site to 9 and fix any issues.  I am a little nervous about the Thunder situation causing issues.

11 posts, 0 answered