+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Unable to install / activatie module builder after upgrade

Unable to install / activatie module builder after upgrade

3 posts, 0 answered
  1. Rick
    Rick avatar
    14 posts
    Registered:
    02 Feb 2012
    14 Sep 2012
    Link to this post
    Hello,

    I've recently updated my website to version 5.1 (3270). Following the steps like described in the manual (4.4 > 5.0 > 5.1). The problem is my module builder isn't installed correctly and gives the following error message:



    The module builders contains 2 active modules and 1 inactive, all build in version 4.4.
    Does anyone have any idea how I can fix the module builder again without losing the modules created (and especially the data it's containing).


    //Edit:
    While digging a little further I found the following line in the systemconfig:
    <add version="5.0.2860.0" errorMessage="An item with the same key has already been added." name="ModuleBuilder" />

    So I'm guessing it already failed when going to 5.0. Adding the right version number manually...
    <add version="5.1.3270.0" name="ModuleBuilder" />
    ...fixes it partially. I can acces the modules in the backend again on the administrator tab, except when going to the pages under content and selecting the module created results in a object reference error.



    I already update all the .dll's from the empty project in case something wasn't copied correctly, but that didn't help.

    Thanks,
    Rick.
  2. Renzen
    Renzen avatar
    2 posts
    Registered:
    15 Mar 2016
    28 Mar
    Link to this post
    Hi Sir I have same problem please see attached file thanks!
  3. Dimitri Cools
    Dimitri Cools avatar
    80 posts
    Registered:
    23 Sep 2016
    30 Mar
    Link to this post
    Hi,

    Please observe following forum thread which you have opened for this issue and where I provided a reply.
    We encourage to keep the communication regarding 1 issue to 1 thread.

    http://www.sitefinity.com/developer-network/forums/bugs-issues-/unable-to-activate-module-builder-after-upgrade-module-failed

    Regards,
    Dimitri Cools
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
3 posts, 0 answered