1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Upgrading Showcases Demo to 5.02800

Upgrading Showcases Demo to 5.02800

3 posts, 0 answered
  1. Matt
    Matt avatar
    35 posts
    Registered:
    01 Nov 2010
    06 Jun 2012
    Link to this post
    Has anyone attempted to upgrade the Showcases Demo to 5.02800?  I was able to get the demo working with 4.4 but when I upgraded I received the following error:

    Could not load file or assembly 'Telerik.Web.UI, Version=2012.1.301.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference.

    By the way, if you're not familiar with the Showcases demo you can download the code and watch the video here:
    http://www.sitefinity.com/blogs/gabesumner/posts/12-01-12/building_real-world_modules_with_sitefinity_rsquo_s_new_module_builder.aspx

    Thanks,
    Matt
  2. Matt
    Matt avatar
    35 posts
    Registered:
    01 Nov 2010
    07 Jun 2012
    Link to this post
    I tried adding the following to the bottom of the web.config, but it didn't help. 
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
            <dependentAssembly>
                <assemblyIdentity name="Telerik.Sitefinity" publicKeyToken="b28c218413bdf563" culture="neutral"/>
                <bindingRedirect oldVersion="4.4.2117.0" newVersion="5.0.2800.0"/>
            </dependentAssembly>
            <dependentAssembly>
                <assemblyIdentity name="Telerik.Web.UI" publicKeyToken="121fae78165ba3d4" culture="neutral"/>
                <bindingRedirect oldVersion="2011.3.1115.40" newVersion="2012.1.215.40"/>
            </dependentAssembly>
         </assemblyBinding>
  3. Matt
    Matt avatar
    35 posts
    Registered:
    01 Nov 2010
    07 Jun 2012
    Link to this post
    It's now working.  I had to recompile again in Visual Studio. 
3 posts, 0 answered