1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Using AJAX inside a custom user control

Using AJAX inside a custom user control

4 posts, 0 answered
  1. Chris
    Chris avatar
    5 posts
    Registered:
    28 Nov 2011
    24 Jan 2012
    Link to this post
    I'm developing some custom pieces for a Sitefinity site as custom user controls that are added to Sitefinity pages.  I have a modal popup extender from the AJAX control toolkit that works in my dev environment, on the live site in an empty template, but not in the actual templates they need to use.  It's using the toolkit ScriptManager

    <ajaxToolkit:ToolkitScriptManager runat="server" ID="ToolkitScriptManager1"></ajaxToolkit:ToolkitScriptManager>

    It looks to me like something coming from ScriptResource.axd might be in conflict with the script manager I'm using but I have no idea how to track this down in Sitefinity.

    I'm not getting any errors when my AJAX isn't working, just that my hidden modal window is always visible instead of being shown/hidden on click.

    Any information that could help me track down the cause would be helpful.
  2. Chris
    Chris avatar
    5 posts
    Registered:
    28 Nov 2011
    24 Jan 2012
    Link to this post
    As I was continuing to debug I noticed that if I put a Google Analytics Script Widget on the template it will break my AJAX.  That's at least one thing the breaks it, so I guess the questions are why and how do I work around it?
  3. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    16 Aug 2017
    27 Jan 2012
    Link to this post
    Hi,

    We have responded to you in the support thread you have open on this issue, please check our response there. For your convenience we're also pasting the response below:

    ".. we have tried reproducing the issue on several local projects but the behavior has been consistently working. Can you please create a test project using our latest officially supported version Sitefinity 4.4 and check  if the issue reproduces there as well? I have recorded a sample video demonstrating the steps we're taking to inspect the issue, please do not hesitate to let me know if we might be missing something.
    "

    Greetings,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Chris
    Chris avatar
    5 posts
    Registered:
    28 Nov 2011
    08 Feb 2012
    Link to this post
    The issue ended up being javascript coding errors in the Google Analytics script we were using, not the Google Analytics widget itself.  We have no issues if we insert a Google Analytics widget with no code.
4 posts, 0 answered