+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Web Deploy for Sitefinity 5.0

Web Deploy for Sitefinity 5.0

6 posts, 0 answered
  1. Richard
    Richard avatar
    15 posts
    Registered:
    17 Aug 2012
    08 Mar 2012
    Link to this post
    Hi,

    When I try to web deploy my Sitefinity 5.0 instance, it gives the following error:

    Copying file Sitefinity\Services\Content\UserFileLibraryService.svc to obj\Release\Package\PackageTmp\Sitefinity\Services\Content\UserFileLibraryService.svc failed. Could not find file 'Sitefinity\Services\Content\UserFileLibraryService.svc'

    This deploying method works with 4.4.

    How would I get around this issue?

    Thanks,
    Rich


    --------------------------------

    Apparently, simply deleting the file worked.
  2. Brian
    Brian avatar
    11 posts
    Registered:
    21 Oct 2008
    09 Mar 2012
    Link to this post
    Same problem here, but two files:

    Unable to copy file "Sitefinity\Services\Content\UserFileLibraryService.svc"
    Unable to copy file "Sitefinity\Services\Content\UserFileService.svc"
  3. Richard
    Richard avatar
    15 posts
    Registered:
    17 Aug 2012
    09 Mar 2012
    Link to this post
    Hi, As far as I can tell, simply excluding the files from the VS project then choosing Deploy all files in the project folder seems to get this working and the site works as normal. It's a workaround, so I guess it's some sort of bug. Hope this gets everything working, as it did for me.
  4. lgroup
    lgroup avatar
    7 posts
    Registered:
    28 Dec 2006
    12 Mar 2012
    Link to this post
    I'm getting same error when trying to check files into TFS.  The solution/project builds with no errors, but when attempting to perform a CheckIn I get:

    Check In: Operation not performed
    Could not find file
    'C:\.....\Sitefinity\Services\Content\UserFileLibraryService.svc'.

    Also happens with UserFileService.svc.

    I excluded them from the project and the CheckIn works properly.

  5. Jen Peleva
    Jen Peleva avatar
    568 posts
    Registered:
    10 Nov 2016
    12 Mar 2012
    Link to this post
    Hello guys,

    Actually, these two .svc files have been moved and are not part of the solution anymore. However, the problem occurs, because your projects keep referencing them and practically search for files that don't exist anymore. The solution to this issue is to remove the files (UserFileLibraryService.svc, UserFileService.svc) from your project in VS and rebuild it (as @Richard properly pointed out). Then you should be able to deploy your projects successfully.

    Regards,
    Jen Peleva
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    22 Mar 2012
    Link to this post
    Thanks guys, it helped me.
6 posts, 0 answered