1-888-365-2779
+1-888-365-2779
Try Now
More in this section

3.6 upgrade

4 posts, 0 answered
  1. Dave
    Dave avatar
    8 posts
    Registered:
    23 Apr 2008
    27 Mar 2009
    Link to this post
    We upgraded our site in our test/stage server environment from SF 3.2 to 3.6.

    Our home page is set to a page named "index.aspx".  Prior to the upgrade, users could enter http://[siteaddress.com] without any page reference and SF would automatically return our home page.

    After the upgrade, we now get a 404 error referring to our /index.aspx file as missing, renamed, or missing a dependent file, etc.  ..... we can only get the index.aspx page to load if we include the page name specifically in the URL address like http://[siteaddress.com]/index.aspx .

    Did we miss an important upgrade step or overlook a significant difference in the SF product from version 3.2 to 3.6?

    Thanks,
    Alan
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    28 Mar 2009
    Link to this post
    Hello Alan,

    Try to publish your home page after you have set it as home again. Let me know if this fix the problem.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
  3. Dave
    Dave avatar
    8 posts
    Registered:
    23 Apr 2008
    28 Mar 2009
    Link to this post
    I made an edit to the home page and published it again.  Still have the same problem.  Any other suggestions?

    Thanks,
    Alan
  4. Vlad
    Vlad avatar
    498 posts
    Registered:
    19 Jun 2017
    31 Mar 2009
    Link to this post
    Hi Alan,

    We found that the problem is related to a bug in the CmsHttpModule when redirectToHomePage attribute is set to false in the /telerik/cms section element in the web.config.
    The fix will be included in the service pack.

    Basically, you can stop the 404 error, if you set redirectToHomePage to true:
            <cms defaultProvider="Sitefinity" redirectToHomePage="true" pageExtension=".aspx" disabled="false" pageEditorUIMode="Overlay"
     

    However, this will change the current behavior, so if you access:
    http://[siteaddress.com]
    it will redirect you to:
    http://[siteaddress.com]/index.aspx

    In case, you want to keep the current behavior, you can use the following temporary workaround:
    1. Create CmsHttpModuleFix class in the App_Code:
    using System; 
    using System.Collections.Generic; 
    using System.Web; 
    using Telerik.Cms.Web; 
     
    // Remove this class after upgrading to Sitefinity 3.6 SP1 
    public class CmsHttpModuleFix : CmsHttpModule 
        protected override string GetUrl(HttpContext context) 
        { 
            if (!Telerik.Cms.Configuration.ConfigHelper.Handler.RedirectToHomePage) 
            { 
                CmsHttpRequest request = CmsHttpRequest.Current; 
                if ((request.Path.Length == 0) 
                    || request.Path.Equals("/"
                    || request.PathLower.Equals(UrlHelper.DefaultDocumentUrl, StringComparison.OrdinalIgnoreCase) 
                    || request.PathLower.Equals(UrlHelper.LowerApplicationPath.TrimEnd('/'))) 
                { 
                    if (UrlHelper.HomePage.IsValid) 
                    { 
                        if (!UrlHelper.HomePage.UrlResolved.Equals(UrlHelper.DefaultDocumentUrl, StringComparison.OrdinalIgnoreCase) 
                            && !UrlHelper.HomePage.UrlResolved.Equals(request.Path, StringComparison.OrdinalIgnoreCase)) 
                        { 
                            request.Initialize(UrlHelper.HomePage.UrlResolved, true); 
                        } 
                    } 
                } 
            } 
            return base.GetUrl(context); 
        } 
     

    2. Replace the default CmsHttpModule declaration in the web.config:
    <add name="Cms" type="CmsHttpModuleFix, App_Code"/> 

    In case your site is running on Classic pipeline mode, you should replace the module in the /system.web/httpModules . If the pipeline mode is Integrated, replace it in the /system.webServer/modules section.



    We are sorry for the inconvenience. Your telerik points were updated.

    Sincerely yours,
    Vlad
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
Register for webinar
4 posts, 0 answered