1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Ajax Tabs

13 posts, 0 answered
  1. Daniel
    Daniel avatar
    62 posts
    Registered:
    20 Apr 2009
    10 Jun 2010
    Link to this post
    Hi support,

    I have an issue with ajax tabs where i have them in a user control when i drag them on to the page in sitefinity the placeholder says only one scriptmanager can be on the page at one time well there is only one (as far as i am aware!)

    Any I save the page and preview and it looks fine the tabs work correctly however if i navigate to the page in the site like normal (not preview mode) the tab container has a style attribute - visiibility:hidden.

    I do not no where this has come from and why it works in preview mode but not in real mode.

    Any help would be greatfully appreciated

    Thanks

    Daniel
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    10 Jun 2010
    Link to this post
    Hi Daniel,

    The ScriptManager should be declared in your master page inside the form tag. If you have an instance of ScriptManager in the control you have to remove it from there.
    visibility is a css property, so you could check from where it comes from by using FireFox - FireBug, IE or Chrome Developer Tools.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Daniel
    Daniel avatar
    62 posts
    Registered:
    20 Apr 2009
    10 Jun 2010
    Link to this post
    Hi Ivan,

    I do only have one instance of the script manager.

    I have looked at the properties in firebug and it is an element style and is not coming from the CSS/Theme files.

    Thanks for your speedy reply

    Daniel
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    10 Jun 2010
    Link to this post
    Hi Daniel,

    Can you send some code that you are using or simplified version of it?

    Regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Daniel
    Daniel avatar
    62 posts
    Registered:
    20 Apr 2009
    10 Jun 2010
    Link to this post
    <%@ Register TagPrefix="cc1" Namespace="AjaxControlToolkit" Assembly="AjaxControlToolkit" %>
     
     
    <cc1:TabContainer ID="AjaxTabs" runat="server">
        <cc1:TabPanel ID="tpGeneral" runat="server">
            <HeaderTemplate>
                General</HeaderTemplate>
            <ContentTemplate>
                The General Content Taken from the Order goes here:
                <p>
                    Quantity:<br />
                    Amount:<br />
                    Discount:
                </p>
            </ContentTemplate>
        </cc1:TabPanel>
        <cc1:TabPanel ID="tpShipTo" runat="server">
            <HeaderTemplate>
                Ship To</HeaderTemplate>
            <ContentTemplate>
                If a different ship to address is used enter it here:<br />
            </ContentTemplate>
        </cc1:TabPanel>
            <cc1:TabPanel ID="tpSubscriptions" runat="server" Visible="False">
            <HeaderTemplate>
                Subscription</HeaderTemplate>
            <ContentTemplate>
                Subscriber:<br />
                Subscription Copies:
            </ContentTemplate>
        </cc1:TabPanel>
        <cc1:TabPanel ID="tpComments" runat="server">
            <HeaderTemplate>
                Comments</HeaderTemplate>
            <ContentTemplate>
                <asp:TextBox ID="tbComments" runat="server" TextMode="MultiLine"></asp:TextBox></ContentTemplate>
        </cc1:TabPanel>
    </cc1:TabContainer>
    That is all the code i am using I have no code behind etc.

    Thanks

    Daniel
  6. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    10 Jun 2010
    Link to this post
    Hi Daniel,

    Could you check the master pages you are using? I have tried your control on a sample website with the attached master pages and they are working properly. Note that in the master page I am using the AjaxToolkit's script manager as opposed to using the default ASP.NET one.

    Regards,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  7. Daniel
    Daniel avatar
    62 posts
    Registered:
    20 Apr 2009
    10 Jun 2010
    Link to this post
    Hi Radoslav,

    I cant make sense of the problem as one minute I am told that only one script manager is allowed on the page one a look at the page source show me there are none let alone more than one.

    When I Preview the page it works fine and the preview section in sitefinity it works fine but when i navigate to it properly it doesnt display.

    I have added a script manager to the page for the page then to error telling me that there is more than one although i can not see it!

    Thanks for your help

    Dan
  8. Daniel
    Daniel avatar
    62 posts
    Registered:
    20 Apr 2009
    01 Jul 2010
    Link to this post
    Hi guys

    I still cant get my tabs to display - like i said they work fine in the preview mode of sitefinity but when i navigate to them they are hidden.

    Daniel
  9. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    02 Jul 2010
    Link to this post
    Hello Daniel,

    Could you please show us how your master page looks like.

    In my previous response I have attached a sample master page which had the AjaxToolking script manager control and the controls were working properly.

    Sincerely yours,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. Daniel
    Daniel avatar
    62 posts
    Registered:
    20 Apr 2009
    02 Jul 2010
    Link to this post
    <%@ Master Language="VB"%>
     
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
     
    <html xmlns="http://www.w3.org/1999/xhtml"  xml:lang="en" lang="en">
    <head runat="server">
        <meta http-equiv="content-type" content="text/html; charset=utf-8" />
     
        <title></title>
        <LINK REL="SHORTCUT ICON" HREF="/favicon.ico">
    <!--[if IE]> <link rel="stylesheet" type="text/css" href="_css/all-ie.css" /> <![endif]-->
    </head>
     
    <body id="about">
        <form id="form1" runat="server">
     
    <div id="page" class="clearfix">
    <div id="page-inner">
     
    <!-- BEGIN NAVIGATION DIV -->
    <div id="navigation">
    <asp:contentplaceholder id="NavigationPlaceHolder" runat="server"></asp:contentplaceholder>           
    </div>
    <!-- END NAVIGATION DIV -->
     
    <!-- BEGIN HEADER DIV -->
    <div id="header">
    <div id="header-inner">
    <asp:contentplaceholder id="HeaderPlaceHolder" runat="server"></asp:contentplaceholder>           
    </div>
    </div>
    <!-- END HEADER DIV -->
     
    <!-- BEGIN SIDEBAR DIV -->
    <div id="sidebar" class="clearfix">
     
    <asp:contentplaceholder id="SubNavPlaceHolder" runat="server"></asp:contentplaceholder>           
     
    <asp:contentplaceholder id="SearchPlaceHolder" runat="server"></asp:contentplaceholder>           
     
    <div class="sidebar-callout">
    <asp:contentplaceholder id="FeatureAreaPlaceHolder" runat="server"></asp:contentplaceholder>           
    </div>
     
    <asp:contentplaceholder id="TopLevelNavListPlaceHolder" runat="server"></asp:contentplaceholder>           
     
    <div class="contact-info">
    <asp:contentplaceholder id="ContactInfoPlaceHolder" runat="server"></asp:contentplaceholder>           
    </div>
     
    </div>
    <!-- END SIDEBAR DIV -->
     
    <!-- BEGIN CONTENT DIV -->
    <div id="content">
    <h1><asp:contentplaceholder id="TitlePlaceHolder" runat="server"></asp:contentplaceholder></h1>
    <asp:contentplaceholder id="MainContentAreaPlaceHolder" runat="server"></asp:contentplaceholder>
     
    </div>
    <div style="clear:both;"></div>
    <!-- END CONTENT DIV -->
     
    </div>
    </div>
     
    <div id="footer">
    <asp:contentplaceholder id="FooterPlaceHolder" runat="server"></asp:contentplaceholder>
    </div>
        </form>
    </body>
    </html>
    Above is my Master page.

    Thanks

    Dan
  11. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    02 Jul 2010
    Link to this post
    Hello Daniel,

    The master page does not contain script manager. I have attached the master page and user control I have used to see if everything works. There are no problems on our side.

    Sincerely yours,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  12. Daniel
    Daniel avatar
    62 posts
    Registered:
    20 Apr 2009
    02 Jul 2010
    Link to this post
    Hi Radoslav,

    It appears to be a conflict with a control on the masterpage - I have a component art menu and if i remove this the tabs display perfectly.

    Thanks for you help if you no of any work arounds for this i would greatly appreciate it

    Thanks

    Dan
  13. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    02 Jul 2010
    Link to this post
    Hello Daniel,

    You can try the CA tool and your user control on a regular .aspx page. If they do not work together there, then I am afraid that you have to look for help at CA.

    Kind regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
13 posts, 0 answered