1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / .asp page extension

.asp page extension

14 posts, 0 answered
  1. Duncan Evans
    Duncan Evans avatar
    122 posts
    Registered:
    07 Jul 2009
    25 Jul 2009
    Link to this post
    I seem to be having issues getting different page extensions working. .html and .asp do now work.

    I have set a URL of one of the pages of my project to ~/index.asp... I get the following error when trying to access it:

    Server Error in '/TRPv3' Application.

    This type of page is not served.

    Description: The type of page you have requested is not served because it has been explicitly forbidden.  The extension '.asp' may be incorrect.   Please review the URL below and make sure that it is spelled correctly.

    Requested URL: /TRPv3/index.asp


    Version Information: Microsoft .NET Framework Version:2.0.50727.3053; ASP.NET Version:2.0.50727.3053




    When i try ~/index.html i get this:



    Server Error in '/TRPv3' Application.

    The resource cannot be found.

    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

    Requested URL: /TRPv3/index.html


    Version Information: Microsoft .NET Framework Version:2.0.50727.3053; ASP.NET Version:2.0.50727.3053


    I have the .* and .template extensions in IIS and set the 404 custom error setting to /TRPv3/sf404.aspx... No change....

    Anyone have any ideas why i am unable to do this?

    Duncan
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    25 Jul 2009
    Link to this post
    Hello Duncan Evans,

    Do these pages (asp and html) exist under "/TRPv3/"? Can you access them by typing the url in the browser bar?

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Duncan Evans
    Duncan Evans avatar
    122 posts
    Registered:
    07 Jul 2009
    27 Jul 2009
    Link to this post
    No there do not "exist"... Only as additional URL's of one of my CMS pages... Like in the properties where you can add URL's...

    Duncan
  4. Duncan Evans
    Duncan Evans avatar
    122 posts
    Registered:
    07 Jul 2009
    29 Jul 2009
    Link to this post
    Any idea what is going on here?
  5. Gabe Sumner
    Gabe Sumner avatar
    440 posts
    Registered:
    09 Sep 2007
    29 Jul 2009
    Link to this post
    I'm not sitting at my regular computer and thus don't have the resources to test this at my disposal.  However, I found the following links; do these help?

    http://classicasp.aspfaq.com/general/why-does-iis-hang-and/or-stop-serving-asp-pages.html

    http://stackoverflow.com/questions/431233/cassini-error-this-type-of-page-is-not-served


    The first link seems to deal with enabling Classic ASP, which you probably don't want to do.

    The second link seems to suggest that some extensions might be forbidden in the global web.config.

    Sorry I can't test either of these as solutions.  This is the direction I would start investigating however.

    Gabe Sumner
    http://www.sitefinitywatch.com/
  6. Duncan Evans
    Duncan Evans avatar
    122 posts
    Registered:
    07 Jul 2009
    29 Jul 2009
    Link to this post
    Thanks for the help Gabe,

    I added this to the web.config:

    <add verb="GET" path="*.asp" type="Telerik.Cms.Engine.ContentHttpHandler, Telerik.Cms.Engine" />

    Now for .asp pages i get the 404 not found error....

    404's in IIS are set to go to sf404.aspx

    I have no idea what is going on here... I really need to sort this out because the previous website was a asp site, so i need to have all the old URL's point to the new aspx pages... I thought this would be as easy as adding them as additional URL's on the page...

    Any further help would be awesome.

    Duncan
  7. Duncan Evans
    Duncan Evans avatar
    122 posts
    Registered:
    07 Jul 2009
    29 Jul 2009
    Link to this post
    None of these URL's work except for the .aspx URL's

    http://www.therecoveryplace.net/version3.0/snapshot.gif

    Duncan


  8. Gabe Sumner
    Gabe Sumner avatar
    440 posts
    Registered:
    09 Sep 2007
    29 Jul 2009
    Link to this post
    Ah.  That makes it sound like it's the 404 redirect that isn't working.

    Can you take a screenshot of the 404 error (including the URL) as well as the 404 setting in IIS?

  9. Duncan Evans
    Duncan Evans avatar
    122 posts
    Registered:
    07 Jul 2009
    29 Jul 2009
    Link to this post
    404 setup in IIS:
    http://www.therecoveryplace.net/version3.0/iis404.gif

    Error page in browser:
    http://www.therecoveryplace.net/version3.0/errorsnapshot.gif

    Mapping of .asp (default iis setting)
    http://www.therecoveryplace.net/version3.0/aspmapping.gif

    When i remove <add verb="*" path="*.asp" type="Telerik.Cms.Engine.ContentHttpHandler, Telerik.Cms.Engine" /> from web.config file:
    http://www.therecoveryplace.net/version3.0/noconfigsetting.gif
  10. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    30 Jul 2009
    Link to this post
    Hi Duncan Evans,

    Generally, everything that you should do is the following:

    1. Set the custom errors, 404 error to be redirected to ~/project/sf404.aspx. You already did that.
    2. Add the custom extensions you want to use with Sitefinity in the additionalExtensions attribute:
    <cms defaultProvider="Sitefinity"  
         pageExtension=".aspx"  
         additionalExtensions=".asp, .htm, .do"  
         disabled="false" 
         pageEditorUIMode="Overlay"  
         redirectToHomePage="false" > 

    IIS7 is usually configured to pass everything to the Asp.Net isapi, but this is not the case for IIS6. That is why you can add wildcard mapping or ensure that these extensions will be processed (mapped to) by Asp.Net ISAPI.

    Let me know about the results.

    Kind regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the newTelerik Support Portal.
    Check out the tipsfor optimizing your support resource searches.
  11. Duncan Evans
    Duncan Evans avatar
    122 posts
    Registered:
    07 Jul 2009
    30 Jul 2009
    Link to this post
    Georgi,

    You always come to the rescue! Adding wildcard mapping acctually causes some of the ajax functions of the admin section to produce errors... But i ma going to forget i saw this and move on.

    Adding the lines you said and them mapping .asp to ISAPI worked...

    Thanks!

    Duncan
  12. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    03 Aug 2009
    Link to this post
    Hi Duncan Evans,

    I am glad this worked for you. 
    Let me know if you have any more questions, I will be glad to assist where I can :)

    Sincerely yours,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the newTelerik Support Portal.
    Check out the tipsfor optimizing your support resource searches.
  13. Duncan Evans
    Duncan Evans avatar
    122 posts
    Registered:
    07 Jul 2009
    19 Aug 2009
    Link to this post
    Hi guys this has just presented a new issue for me... I have setup Sitefinity to handle .html files. In the IIS extensions i have setup .html extension to be handled by .NET...

    Now when trying to access a html page that does not exist on the server, they is no 404 html response being returned, whihc Google Webmaster Tools is freaking out about (For site verification)!

    I need 404 erros return when html files do not exist and i need Sitefinity to handel html extensions. Can someone help me make this work as it should?

    Duncan
  14. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    24 Aug 2009
    Link to this post
    Hi Duncan Evans,

    This should be default behavior. I am testing with 3.6 SP2:
    1. Found - this image represents the response codes when the html page is found
    2. Not-Found - when the page is not found. 

    Again, my configuration is: 

    1. 404 custom errors are set to sf404.aspx in the web.config file
    2. html is added to the additional extensions collection. 

    Can you please inspect the response codes using Fiddler for example? It is a free tiny application which will show you everything related to requests and responses. 

    Sincerely yours,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the newTelerik Support Portal.
    Check out the tipsfor optimizing your support resource searches.
Register for webinar
14 posts, 0 answered