+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Common custom content view for all generic module

Common custom content view for all generic module

8 posts, 0 answered
  1. Tarun
    Tarun avatar
    81 posts
    Registered:
    14 Jan 2009
    20 Dec 2010
    Link to this post
    Hi,

    I am trying to create a Common content view control for my all GC Module. I am thinking to wrap two sitefinity control "Generic content view " and "Categories List" control on a single user control to achieve functionality showing in the attachment. Is it possible to wrap them on user control or you guys have some other suggestion for this.

    Please take a look on attachment for better understanding.

    Thanks for your reply!

    Regards,
    Tarun 
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    20 Dec 2010
    Link to this post
    Hi Tarun,

    You should better use custom control - class library. ContentView controls and Generic Content control does not work properly when it is wrapped in a user control.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Tarun
    Tarun avatar
    81 posts
    Registered:
    14 Jan 2009
    20 Dec 2010
    Link to this post
    Hi Ivan,

    Could you tell me bit more about the Class library you are talking about ,How  would I make that for content view with category search?

    I am looking forward for you reply!

    Thanks,
    Tarun


  4. Tarun
    Tarun avatar
    81 posts
    Registered:
    14 Jan 2009
    21 Dec 2010
    Link to this post
    Hi Ivan,

    I made that library for content view but when I put this on user control and added this with category search UI(as in attachment) to achieve category search. Search does work but the single item url does not work to navigate single page it says item not found.

    Could you help me out?

    Thanks for you reply!

    Regards,
    Tarun
  5. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    21 Dec 2010
    Link to this post
    Hi Tarun,

    How do you resolve the single item url and do you have a ContentView control on a page that will show the item?

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Tarun
    Tarun avatar
    81 posts
    Registered:
    14 Jan 2009
    21 Dec 2010
    Link to this post
    Thanks Ivan for quick reply!

    My custom contentview control(class library) is inside usercontrol which show the content lists fine. but when I click the item it does not show me full content.

    If i put a generic contentview on page and provide provider name then that show me single item too but my custom contentview inside usercontrol does not show.

    Regards,
    Tarun
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    21 Dec 2010
    Link to this post
    Hello Tarun,

    Please check this KB.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Tarun
    Tarun avatar
    81 posts
    Registered:
    14 Jan 2009
    12 Jan 2011
    Link to this post
    Thanks Ivan for your help!
Register for webinar
8 posts, 0 answered